Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] 1.3.2rc1 has escaped
From: Samuel Thibault (samuel.thibault_at_[hidden])
Date: 2012-02-08 19:46:07


Samuel Thibault, le Thu 09 Feb 2012 01:43:56 +0100, a écrit :
> Paul H. Hargrove, le Thu 09 Feb 2012 01:41:47 +0100, a écrit :
> > On 2/8/2012 4:31 PM, Samuel Thibault wrote:
> > >Paul H. Hargrove, le Thu 09 Feb 2012 01:28:53 +0100, a écrit :
> > >>Option #4:
> > >> CFLAGS='-qhalt=e -qsuppress=1506-077'
> > >>Appears to work for me for xlc-8.0 and xlc-9.0.
> > >That still looks dangerous to me: we don't know whatever warning
> > >might be added in the future. I'd rather add -qhalt=e only for the
> > >sched_setaffinity test.
> >
> > I don't recommend adding -qsuppress automatically, just documenting it for
> > users that need xlc-8 or xlc-9.
>
> I'm not actually talking about the -qsuppress, but about still using
> -qhalt=e, which might make a lot more other warnings fatal.

(and I mean that adding just one -qsuppress is not enough, other
warnings could arise, and then we'd need more -qsuppress, but we don't
know yet which, etc.)

Samuel