Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] hwloc-1.3.1 and 1.4 failures on MIPS64/qemu
From: Paul H. Hargrove (PHHargrove_at_[hidden])
Date: 2012-02-03 19:33:50


On 2/3/2012 1:23 PM, Paul H. Hargrove wrote:
> On 2/3/2012 11:52 AM, Paul H. Hargrove wrote:
>> Building from the trunk w/ CFLAGS="-march=5kc -mabi=64" I no longer
>> see any test failures.
>
> I can report success with -mabi=32 and -mabi=n32 as well.
>
> I've finally been able to get Debian squeeze booted under
> qemu-system-mips64.
> I am dropping my hybrid lenny/etch-and-a-half system in favor of this
> new one.
> I'll retest, but only plan to report to hwloc-devel if results differ
> from before.

Some more information on this subject.

I now have 2 qemu-emulated MIPS64 systems (5kc cpus).
Both are the same qemu version (0.15.1)

I am using hwloc-1.5a1r4246 (the svn trunk tarball from lastnight).
So, I am NOT expecting Samuel's recent fix in this build.

+ One running Debian Squeeze passed "make all install check" for all 3
ABIs, as reported above.
+ One running Debian Lenny passed the default (32) ABI, but fails as
before for "64" and "n32" ABIs:
> -Latency matrix between 16 PUs (depth 4) by logical indexes (below
> Machine L#0):
> +Latency matrix between 16 PUs (depth 3) by logical indexes (below
> Machine L#0):

This time I have a completely "pure" Lenny system from scratch (no etch
or etch-and-a-half bits).
So, I think I am in agreement w/ Samuel that Lenny "has issues".

-Paul

-- 
Paul H. Hargrove                          PHHargrove_at_[hidden]
Future Technologies Group
HPC Research Department                   Tel: +1-510-495-2352
Lawrence Berkeley National Laboratory     Fax: +1-510-486-6900