Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] hwloc-1.4 "gmake check" failure on Solaris-10/SPARC/gccfss [PATCH]
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2012-02-02 16:07:36


My $0.02 is that we should disable FFS on all versions of that compiler. It's not like this is performance-critical code. I'd rather it be "slow" and guaranteed correct than fast and maybe wrong.

Meaning: I'm good with Paul's patch. I'll commit, since no one has posted any alternatives.

On Feb 2, 2012, at 6:00 AM, Samuel Thibault wrote:

> Paul H. Hargrove, le Thu 02 Feb 2012 02:29:08 +0100, a écrit :
>> + The configure-time logic is NOT trying to determine the version number, as
>> I don't have a way (yet?) to pinpoint which version(s) work correctly, and
>> the Oracle Forums thread on the subject doesn't say. So, it is
>> conservatively assuming all "gccfss" versions are broken.
>
> We don't necessarily need to be precise, suffice to know that at least
> from some version the bug was fixed, and be fine with spuriously use the
> generic code with old non-broken gccfss.
>
> Samuel
> _______________________________________________
> hwloc-devel mailing list
> hwloc-devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/hwloc-devel

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/