Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [hwloc-devel] hwloc-1.3.1 and 1.4 failures on MIPS64/qemu
From: Paul H. Hargrove (PHHargrove_at_[hidden])
Date: 2012-02-02 15:19:55


Samuel Thibault wrote:
> Paul H. Hargrove, le Wed 01 Feb 2012 06:50:12 +0100, a écrit :
>
>> The failure is only w/ {C,CXX}FLAGS=-mabi=64.
>> With the "32" or "n32" ABI's there is no problem.
>> That is why it was not seen on the 32-bit system.
>>
>
> I have tested on a debian porter machine, mips64, without problem. Is it
> a mipsel emulated system? Actually, can you simply tell us the qemu
> command line? :)
>
> Samuel
>
>
Not a mipsel (I have access to a physical one of those).

$ qemu-system-mips64 -cpu 5Kc -M malta -m 256 .....
I configured hwloc w/ CFLAGS='-march=5kc -mabi=64'

-Paul

-- 
Paul H. Hargrove                          PHHargrove_at_[hidden]
Future Technologies Group
HPC Research Department                   Tel: +1-510-495-2352
Lawrence Berkeley National Laboratory     Fax: +1-510-486-6900