Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] topology-solaris-chiptype.c bugs on processortype
From: TERRY DONTJE (terry.dontje_at_[hidden])
Date: 2012-01-18 12:59:28


On 1/18/2012 12:51 PM, Samuel Thibault wrote:
> Samuel Thibault, le Wed 18 Jan 2012 15:55:18 +0100, a écrit :
>> I'm getting an issue with the topology-solaris-chiptype.c work on
>> Solaris 10: in the ProcessorType case, the returned value does not look
>> like a readable string, I'm getting "¨", which consequently poses
>> problems in the xml parser. Of course, googling picl_get_propinfo
>> "ProcessorType" returns... topology-solaris-chiptype.c ...
>>
>> Can somebody have a look?
> using ptrpicl -v, I'm getting
>
> :name cpus
> cpu (cpu, 8900000735)
> :StateBegin Wed Jan 18 07:18:41 2012
> :FPUType<ERROR: Argument too big>
> :ProcessorType \360\275^T^H
>
> which matches what I'm getting with hwloc (0xf0 0xbd 0x14 0x8...) (yes,
> it's different from by previous report because my job request got
> another but similar hardware machine).
Weird, my prtpicl on my v20z (which is a Sun system) has readable fields
FPUType and ProcessorType.
However, I am using an older S10 Generic_120012-11. I'll see if I can
find something newer to try.

--td
> pkginfo reports picl packages as being the following version:
>
> VERSION: 11.10.0,REV=2005.01.21.16.34
> PSTAMP: on10ptchfeatx20080814051153
>
> Samuel

-- 
Oracle
Terry D. Dontje | Principal Software Engineer
Developer Tools Engineering | +1.781.442.2631
Oracle *- Performance Technologies*
95 Network Drive, Burlington, MA 01803
Email terry.dontje_at_[hidden] <mailto:terry.dontje_at_[hidden]>



picture