Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] [hwloc-svn] svn:hwloc r4041
From: Brice Goglin (Brice.Goglin_at_[hidden])
Date: 2011-12-13 12:19:23


You should also error out if --enable-cuda is given and cuda isn't
found. We got some complains about this for XML and PCI. Just duplicate
the xml_happy stuff for cuda.

Brice

Le 13/12/2011 18:15, sthibaul_at_[hidden] a écrit :
> Author: sthibaul
> Date: 2011-12-13 12:15:09 EST (Tue, 13 Dec 2011)
> New Revision: 4041
> URL: https://svn.open-mpi.org/trac/hwloc/changeset/4041
>
> Log:
> add --disable-cuda
> Text files modified:
> branches/cuda/config/hwloc_internal.m4 | 5 +++++
> 1 files changed, 5 insertions(+), 0 deletions(-)
>
> Modified: branches/cuda/config/hwloc_internal.m4
> ==============================================================================
> --- branches/cuda/config/hwloc_internal.m4 (original)
> +++ branches/cuda/config/hwloc_internal.m4 2011-12-13 12:15:09 EST (Tue, 13 Dec 2011)
> @@ -65,6 +65,11 @@
> AS_HELP_STRING([--disable-pci],
> [Disable the PCI device discovery using libpci]))
>
> + # CUDA?
> + AC_ARG_ENABLE([cuda],
> + AS_HELP_STRING([--disable-cuda],
> + [Disable the CUDA device discovery using libcudart]))
> +
> # Linux libnuma
> AC_ARG_ENABLE([libnuma],
> AS_HELP_STRING([--disable-libnuma],
> _______________________________________________
> hwloc-svn mailing list
> hwloc-svn_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/hwloc-svn