Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] Something lighter-weight than XML?
From: Brice Goglin (Brice.Goglin_at_[hidden])
Date: 2011-09-01 12:17:01


Le 01/09/2011 18:01, Jeff Squyres a écrit :
> I could *probably* write this, but I'm guessing you guys could write it much faster than I could...

Support for the most useful attributes would be done within a couple
hours. The annoying thing is to support all attributes, distances, ...

Also we'd need to find a good name for this new backend. Something away
from "text" because we already have the txt and ncurses outputs in
lstopo :) Maybe "hwloc". hwloc_topology_export_hwlocbuffer() and "lstopo
foo.hwloc" :) Or "htx" for "hwloc tiny xml".

Brice