Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [hwloc-devel] pgi 11.1
From: Brice Goglin (Brice.Goglin_at_[hidden])
Date: 2011-03-07 04:54:00


Le 01/03/2011 14:00, Brice Goglin a écrit :
> I just tried a PGI compiler 11.1 and couldn't compile hwloc trunk, v1.1
> or even v1.0. All of them fail in the libxml headers.

This is a problem with libxml2 2.7.1 (SLES11). Rebuilding a libxml2
2.7.8 fixes the problem.

> If I disable XML, it fails during link:
>
> libtool: link: /opt/cluster/compiler/pgi/linux86-64/latest/bin/pgcc -shared -fpic -DPIC .libs/topology.o .libs/traversal.o .libs/topology-synthetic.o .libs/bind.o .libs/cpuset.o .libs/misc.o .libs/topology-linux.o .libs/topology-x86.o -lc -Wl,-soname -Wl,libhwloc.so.0 -o .libs/libhwloc.so.0.2.0
> /usr/bin/ld: /opt/cluster/compiler/pgi/shared/11.1/lib64/libpgbind.a(bindsa.o): relocation R_X86_64_PC32 against undefined symbol `syscall@@GLIBC_2.2.5' can not be used when making a shared object; recompile with -fPIC
> /usr/bin/ld: final link failed: Bad value
> make[1]: *** [libhwloc.la] Error 2
>

This is solved in PGI 11.2.

hwloc trunk compiles fine now.

Brice