Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [hwloc-devel] Man pages and gather-topology
From: Brice Goglin (Brice.Goglin_at_[hidden])
Date: 2011-01-20 07:01:29


Le 20/01/2011 12:23, Jeff Squyres (jsquyres) a écrit :
> I ran some quick tests on the rc1 tarball and ran into problems with the get-API man page and the gather-topology scripts (ie they weren't there and make install failed).
>
> Could you guys have a look?
>
>

The online tarball doesn't build here either. It doesn't contain the
gather-topology.1in manpage. But make dist (and distcheck) in v1.1
branch work fine here.

I don't know what happen during your make dist. Apart from the missing
manpage. Your tarball contains all files that configure and make
generates (Makefile, .deps, .o, .libs). Your doxygen also created
additional files with -e prefix for each expected html and manpages.

I don't see anything wrong with get_api_version. Once I manually worked
around the missing manpage, make worked fine.

FWIW, you used autoconf 2.68 and doxygen 1.7.2. I use 2.67 and 1.7.1.
Which machine/distrib did you use?

Brice