Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] Perl bindings question
From: Bernd Kallies (kallies_at_[hidden])
Date: 2011-01-20 04:55:24


Jeff, thanks for the report.

Embarassingly the needed typemap file was not part of the package in
CPAN. This mistake is corrected in

http://cpan.perl.org/authors/id/B/BK/BKA/Sys-Hwloc-0.10.tar.gz

Please give this a try.

To be able to run the full test suite, you will also need to install a
newer Test::More (>= 0.89). This is also available from CPAN.

Regards BK

On Wed, 2011-01-19 at 17:51 -0500, Jeff Squyres wrote:
> Bernd --
>
> I finally got around to trying to play with Sys-Hwloc-0.09 today. But I wasn't able to build it. I'm not enough of a perl module wizard to know what is going on here -- what am I doing wrong?
>
> This is on a RHEL5.5 machine with a local installation of hwloc 1.1 under /root/hg/bootstrap/local.
>
> [root_at_localhost Sys-Hwloc-0.09]# export PKG_CONFIG_PATH=/root/hg/bootstrap/local/lib/pkgconfig/
> [root_at_localhost Sys-Hwloc-0.09]# perl Makefile.PL
> checking for hwloc... yes
> checking for hwloc prefix... /root/hg/bootstrap/local
> checking for hwloc eprefix... /root/hg/bootstrap/local
> checking for hwloc includedir... /root/hg/bootstrap/local/include
> checking for hwloc libdir... /root/hg/bootstrap/local/lib
> checking for hwloc -I flags... -I/root/hg/bootstrap/local/include -I/usr/include/libxml2
> checking for hwloc libs... -L/root/hg/bootstrap/local/lib -lhwloc
> checking if hwloc supports hwloc_get_api_version... no
> checking if hwloc supports XML... yes
> checking HWLOC_API_VERSION... 0x00010100
> Checking if your kit is complete...
> Looks good
> Warning: prerequisite Test::More 0.89 not found. We have 0.62.
> Writing Makefile for Sys::Hwloc
> [root_at_localhost Sys-Hwloc-0.09]# make
> sed -e s/@HWLOC_API_VERSION@/0x00010100/ <lib/Sys/Hwloc.pm >blib/lib/Sys/Hwloc.pm
> AutoSplitting blib/lib/Sys/Hwloc.pm (blib/lib/auto/Sys/Hwloc)
> cp lib/Sys/Hwloc/Obj.pod blib/lib/Sys/Hwloc/Obj.pod
> cp lib/Sys/Hwloc/Cpuset.pod blib/lib/Sys/Hwloc/Cpuset.pod
> cp lib/Sys/Hwloc/Bitmap.pod blib/lib/Sys/Hwloc/Bitmap.pod
> cp lib/Sys/Hwloc/Topology.pod blib/lib/Sys/Hwloc/Topology.pod
> /usr/bin/perl /usr/lib/perl5/5.8.8/ExtUtils/xsubpp -typemap /usr/lib/perl5/5.8.8/ExtUtils/typemap Hwloc.xs > Hwloc.xsc && mv Hwloc.xsc Hwloc.c
> Error: 'hwloc_obj_type_t' not in typemap in Hwloc.xs, line 458
> Error: 'hwloc_obj_type_t' not in typemap in Hwloc.xs, line 459
> Error: 'hwloc_topology_t' not in typemap in Hwloc.xs, line 472
> Error: 'hwloc_topology_t' not in typemap in Hwloc.xs, line 483
> Error: 'hwloc_topology_t' not in typemap in Hwloc.xs, line 506
> Error: 'hwloc_topology_t' not in typemap in Hwloc.xs, line 511
> Error: 'hwloc_topology_t' not in typemap in Hwloc.xs, line 528
> Error: 'hwloc_obj_type_t' not in typemap in Hwloc.xs, line 529
> Error: 'hwloc_topology_t' not in typemap in Hwloc.xs, line 548
> Error: 'hwloc_topology_t' not in typemap in Hwloc.xs, line 561
> Error: 'hwloc_topology_t' not in typemap in Hwloc.xs, line 575
> Error: 'hwloc_topology_t' not in typemap in Hwloc.xs, line 590
> Error: 'pid_t' not in typemap in Hwloc.xs, line 591
> Error: 'hwloc_topology_t' not in typemap in Hwloc.xs, line 606
> Error: 'hwloc_topology_t' not in typemap in Hwloc.xs, line 620
> Error: 'hwloc_topology_t' not in typemap in Hwloc.xs, line 635
> Error: 'hwloc_topology_t' not in typemap in Hwloc.xs, line 662
> Error: 'hwloc_topology_t' not in typemap in Hwloc.xs, line 680
> ...lots more like this (and others)
>

-- 
Dr. Bernd Kallies
Konrad-Zuse-Zentrum für Informationstechnik Berlin
Takustr. 7
14195 Berlin
Tel: +49-30-84185-270
Fax: +49-30-84185-311
e-mail: kallies_at_[hidden]