Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [hwloc-devel] 1.1rc4 released
From: Brice Goglin (Brice.Goglin_at_[hidden])
Date: 2010-12-16 02:12:25


Le 16/12/2010 02:29, Christopher Samuel a écrit :
> make check fails on our CentOS 5.4 box:

We can safely ignore this failure. Can you change the exit line at the
end of tests/linux/gather/test-gather-topology.sh.in into "exit 0",
reconfigure and rerun make check to see if anything else fails?

test-gather-topology.sh and xmlbuffer are veeeeery pedantic. I thought
about ignoring their failure by default in the past because there are
some annoying corner cases where we can't prefectly simulate a remote
topology. Things work almost fine, but you see small differences between
the detailled outputs (XML output here).

In your case, the problem is related to gather-topology.sh not gathering
all the Linux cpuset/cgroup info properly (we would need to parse
/proc/mounts in gather-topology.sh). I will try to fix this in 1.2 (I am
opening a ticket about it). We don't need to delay 1.1 because of this,
so I will ignore the failure.

Brice