Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] hwloc patches for upstream
From: Pavan Balaji (balaji_at_[hidden])
Date: 2010-11-24 17:02:21


On 11/24/2010 07:35 AM, Brice Goglin wrote:
>> 1. Gracefully abort at configure time if the compiler doesn't support
>> C99:
>> https://trac.mcs.anl.gov/projects/mpich2/changeset/7497/mpich2/trunk/src/pm/hydra/tools/bind/hwloc/hwloc
>
> Is this actually still needed?
>
> I get this error when configuring with a gcc that forces -std=c89:
>
> checking for /home/bgoglin/bin/gcc-c89 option to accept ISO C99...
> unsupported
> configure: WARNING: C99 support is required by hwloc
> configure: error: Cannot build hwloc core
> <stop>

Thanks. I see now that the error is being caught in the top-level
configure.ac. I'll discard this patch.

  -- Pavan

-- 
Pavan Balaji
http://www.mcs.anl.gov/~balaji