Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [hwloc-devel] [hwloc-announce] Hardware locality (hwloc) v1.1rc1 released
From: Jirka Hladky (jhladky_at_[hidden])
Date: 2010-11-10 09:02:21


HI Brice,

On Wednesday, November 10, 2010 02:28:46 pm Brice Goglin wrote:
> Le 10/11/2010 14:09, Jirka Hladky a écrit :
> > Hi Brice,
> >
> > I have found couple of issues with 1.1rc2
> >
> > 1) man hwloc-bind
> > Following example does not work:
> > $ hwloc-bind --cpubind node:1 --membind:0 echo hello
> > Unrecognized option: --membind:0
>
> Obvious typo in the manpage (should be --membind node:0), I am fixing this.
Thanks!

>
> > 2) hwloc-bind --get --membind is not working for me (RHEL 6.0)
> > $ hwloc-bind --membind node:1 --mempolicy interleave -- hwloc-bind --get
> > -- membind
> > hwloc_get_membind failed (errno 22 Invalid argument)
>
> You get the same error when running only "hwloc-bind --get --membind",
> right?
Yes:
$ hwloc-bind --get --membind
hwloc_get_membind failed (errno 22 Invalid argument)

> I am not sure about this one. Do you have NUMA support in your kernel?
> Is your machine NUMA? Can you send the gather-topology tarball ? (if we
> don't have it already :))
Yes, it's a NUMA box with NUMA support in kernel.

Both
numactl --membind=0 --physcpubind=1 stream/stream
and
hwloc-bind --cpubind node:1 --membind node:0 stream/stream
works nicely.

I have attached gather-topology tarball.

Thanks for looking into it! Let me know if you need more information.

> > 3)
> > $ hwloc-calc --single socket:0
> > Unrecognized option: --single
>
> Oops, I removed it by mistake, fixing this too.
Great:-)

Thanks
Jirka