Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] roadmap
From: Brice Goglin (Brice.Goglin_at_[hidden])
Date: 2010-09-24 07:30:26


Here's a proposal for the new renamed cpuset API. Non trivial changes
include:
hwloc_cpuset_from_string -> hwloc_bitmap_sscanf
hwloc_cpuset_cpu -> hwloc_bitmap_setonly
hwloc_bitmap_all_but_cpu -> hwloc_bitmap_allbut

My plan would be to:
* commit the attached file as hwloc/bitmap.h
* drop everything from hwloc/cpuset.h, add a big deprecation warning in
the header, make it include bitmap.h, and add typedef/#define for API
backward compat
* port all the internals to the new API
* only #include bitmap.h internally
* add ABI aliases at the end of src/cpuset.c (don't know if it's worth
renaming this file)

By the way, what's the proper way to do the latter?
#pragma weak hwloc_cpuset_foo = hwloc_bitmap_foo ?
use __hwloc_attribute_alias instead ?

Brice