Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] hwloc trouble with the PGI compiler
From: Pavan Balaji (balaji_at_[hidden])
Date: 2010-09-19 09:26:03


Any news on this?

How are other projects using hwloc dealing with this? This failure is
causing the MPICH2 trunk to fail at "make" time with the PGI compilers.
We have a sandbox configure for hwloc, so if it fails at configure time,
MPICH2 can still proceed, but that's not helping in this case. So from
our perspective, if hwloc were to fail, we always want it to fail at
configure time, not make (or make install) time.

Thanks,

  -- Pavan

On 08/03/2010 05:16 PM, Pavan Balaji wrote:
>
> For the time being, can you add a test to the configure to error out in
> this case, instead of failing at make time?
>
> Thanks,
>
> -- Pavan
>
> On 08/01/2010 12:47 PM, Brice Goglin wrote:
>> (forwarding to the list)
>>
>> Looks like another problem with the PGI compiler custom sched.h header.
>> Did anybody ever ask PGI why they do this?
>>
>> Brice
>>
>>
>>
>> -------- Message original --------
>> Sujet: Re: hwloc-devel post from balaji_at_[hidden] requires approval
>> Date : Sun, 01 Aug 2010 12:17:08 -0500
>> De : Pavan Balaji<balaji_at_[hidden]>
>> Pour : Brice Goglin<Brice.Goglin_at_[hidden]>
>>
>>
>>
>> D'oh! I forgot to forward stderr to the files. I've reattached them.
>>
>> -- Pavan
>>
>> On 08/01/2010 04:07 AM, Brice Goglin wrote:
>>> I don't see any error in your attachments.
>>>
>>> Brice
>>>
>>
>> --
>> Pavan Balaji
>> http://www.mcs.anl.gov/~balaji
>>
>

-- 
Pavan Balaji
http://www.mcs.anl.gov/~balaji