Le 07/07/2010 14:17, Jirka Hladky a Ã©crit :
> 1) I would suggest to rename --list to something more descriptive like
I don't like long names like that :) I currently vote for --intersect
here since this option list the indexes of all objects that intersect
the input within the given depth or type.
Find the list of objects of the given type or depth that intersect the CPU set
and report the comma-separated list of their indexes instead of the cpu mask
string. This may be used for determining the list of objects above or below
the input objects. When combined with --physical, the list is convenient to
pass to external tools such as taskset or numactl --physcpubind or --membind.
This is different from --largest since the latter requires that all reported
objects are strictly included inside the input objects.
> 2) I would rename --objects to something like
> or perhaps just
I currently vote for --largest (or something about
summarizing/synthetizing) since this option groups input objects and
summarizes them into larger ancestors.
--largest Report the list of largest objects exactly included of the input objects. None
of these output objects intersect each other, and the sum of them is exactly
equivalent to the input. No largest object is included in the input This is
different from --intersect where reported objects may not be strictly included
in the input.
> You may consider to add option
> --all_ancestors (or perhaps ancestors-tree or family-tree)
> to list the full tree of ancestors objects
This one might be better in hwloc-info (if we split it out of lstopo) or