Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] Strange difference
From: Samuel Thibault (samuel.thibault_at_[hidden])
Date: 2010-03-28 05:29:11


Bert Wesarg, le Sat 27 Mar 2010 09:31:40 +0100, a écrit :
> On Sat, Mar 27, 2010 at 01:50, Jeff Squyres <jsquyres_at_[hidden]> wrote:
> > On Mar 26, 2010, at 5:35 PM, Brice Goglin wrote:
> >
> >> > Fair enough.  How about still just keeping "P" in the graphic output, then?  But "processor" in the prettyprint?
> >>
> >> IIRC, somebody said "PU" (for "processing unit") could be a good
> >> solution. Otherwise, I am ok with "Proc" or "Processor", with a small
> >> preference for the former.
> >
> > I think I still am uncomfortable with "proc" because it's too much like "process".  But that could be just me.
> >
> > PU might be suitable.
> >
> >> By the way, this is also what hwloc_type_string() would return. Unless
> >> we keep it unchanged and just hack lstopo to use its own stringified
> >> type name ?
> >
> > I wouldn't mind the hack (too much), but it does seem a little inelegant.  If we hate everything else, let's settle on "PU".
>
> "PU" may also be a little future safe, when GPU cores become common.

Mmm, but I guess we shouldn't use the same kind of object for those,
since you can not bind usual processes and threads on them.

Samuel