Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] 1.0-rc1
From: Brice Goglin (Brice.Goglin_at_[hidden])
Date: 2010-03-22 18:12:37


Bert Wesarg wrote:
>>>> I would also rename hwloc_cpuset_clearset() to
>>>> hwloc_cpuset_andnotset(), so it fits to the _{or,and,xor,not}set
>>>> naming style (i.e. they are named after the bit operation).
>>>>
>>> I don't like andnotset() at all, sorry.
>>>
>> We could add an alias.
>>
>
> You don't need to add this, really. Maybe include the description of
> the bit operation inside the documentation. I would search for
> and.*not and would find the appropriate function. I can provide some
> wordings for this.
>

If we switch from andset to and (I am looking at it right now), "clear"
would not make sense anyway, so I'd use "andnot" there.

Brice