Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] 1.0-rc1
From: Bert Wesarg (bert.wesarg_at_[hidden])
Date: 2010-03-22 18:06:39


On Mon, Mar 22, 2010 at 22:44, Samuel Thibault <samuel.thibault_at_[hidden]> wrote:
> Brice Goglin, le Mon 22 Mar 2010 22:37:59 +0100, a écrit :
>> Bert Wesarg wrote:
>> > In case of the
>> > binary cpuset operations I find the '<res> = <arg1> op <arg2>' style
>> > more flexible, than the current '<arg1> op= <arg2>' style.
>>
>> Given that you don't like malloc, you really don't want this :)
>
> I guess he meant
>
> hwloc_cpuset_and(hwloc_cpuset_t res, hwloc_const_cpuset_t arg1, hwloc_const_cpuset_t arg2);
>
> arg1 and arg2 being allowed to be equal to res, thus keeping the
> possibility of an arg1 op= arg2 style.

Yes, that was my intention.

>
>> > I would also rename hwloc_cpuset_clearset() to
>> > hwloc_cpuset_andnotset(), so it fits to the _{or,and,xor,not}set
>> > naming style (i.e. they are named after the bit operation).
>>
>> I don't like andnotset() at all, sorry.
>
> We could add an alias.

You don't need to add this, really. Maybe include the description of
the bit operation inside the documentation. I would search for
and.*not and would find the appropriate function. I can provide some
wordings for this.

>
> Samuel
> _______________________________________________
> hwloc-devel mailing list
> hwloc-devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/hwloc-devel
>