Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] 1.0-rc1
From: Brice Goglin (Brice.Goglin_at_[hidden])
Date: 2010-03-22 17:37:59


Bert Wesarg wrote:
> In case of the
> binary cpuset operations I find the '<res> = <arg1> op <arg2>' style
> more flexible, than the current '<arg1> op= <arg2>' style.

Given that you don't like malloc, you really don't want this :) Your
proposal would allocate a new cpuset for each operation. Given how many
"and" or "or" operations we have inside the core library, allocating a
new cpuset for all operations wouldn't be good...

I think the current model is more flexible since you allocate when you
want (with alloc() or by dup()) and then combine things without
allocating anymore.

> I would
> also rename hwloc_cpuset_clearset() to hwloc_cpuset_andnotset(), so it
> fits to the _{or,and,xor,not}set naming style (i.e. they are named
> after the bit operation).
>

I don't like andnotset() at all, sorry.

Brice