Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] [PATCH] Replace readdir() with readdir_r()
From: Samuel Thibault (samuel.thibault_at_[hidden])
Date: 2010-03-18 18:45:01


Brice Goglin, le Thu 18 Mar 2010 23:37:57 +0100, a écrit :
> Samuel Thibault wrote:
> > Brice Goglin, le Thu 18 Mar 2010 22:58:35 +0100, a écrit :
> >> Bert Wesarg wrote:
> >>> Make the linux backend more re-entrant safe by using readdir_r() instead
> >>> of readdir().
> >>
> >> Changing so many lines because of bugs that don't exist yet doesn't
> >> look like a good idea to me.
> >
> > Err, they do already exist. We've just documented that it was safe to
> > work on separate topology objects in different threads, so readdir is
> > indeed an issue :)
>
> Only if using the same directory stream. It's not the case here.

Ah, right, ok.

Samuel