Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] [hwloc-svn] svn:hwloc r1447
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-12-08 13:45:39


What happens if you run configure?

On Dec 8, 2009, at 1:41 PM, Brice Goglin wrote:

> Brice Goglin wrote:
> > Jeff Squyres wrote:
> >
> >> On Dec 8, 2009, at 1:23 PM, Brice Goglin wrote:
> >>
> >>
> >>
> >>> We already have
> >>> LT_PREREQ([2.2.6])
> >>> LT_INIT
> >>> It doesn't seem to actually enforce libtool >= 2.2.6
> >>>
> >>>
> >> Really? That would be surprising -- I don't have LT < 2.2.6 convenient to test with...
> >>
> >>
> >
> >
> > Here's what you get with libtool 1.5.22 and autoconf 2.64 with trunk
> > from yesterday:
> > $ ./autogen.sh
> > autoreconf: Entering directory `.'
> > autoreconf: configure.ac: not using Gettext
> > autoreconf: running: /usr/local/bin/aclocal
> > -I/usr/local/stow/automake-1.11/share/aclocal-1.11/
> > -I/usr/local/stow/libtool-2.2.6/share/aclocal/ --force -I config -I m4
> > autoreconf: configure.ac: tracing
> > autoreconf: running: libtoolize --copy --force
> > Remember to add `AC_PROG_LIBTOOL' to `configure.ac'.
> > You should update your `aclocal.m4' by running aclocal.
> > Putting files in AC_CONFIG_AUX_DIR, `config'.
> > autoreconf: running: /usr/local/stow/autoconf-2.64/bin/autoconf --force
> > autoreconf: running: /usr/local/stow/autoconf-2.64/bin/autoheader --force
> > autoreconf: running: automake --add-missing --copy --force-missing
> > autoreconf: Leaving directory `.'
> >
>
>
> Or even this if I remove libtool-2.2.6 from ACLOCAL (note that
> AC_LIBTOOL_WIN32_DLL appears after LT_PREREQ and LT_INIT)
>
> autoreconf: Entering directory `.'
> autoreconf: configure.ac: not using Gettext
> autoreconf: running: /usr/local/bin/aclocal
> -I/usr/local/stow/automake-1.11/share/aclocal-1.11/ --force -I config -I m4
> autoreconf: configure.ac: tracing
> autoreconf: configure.ac: not using Libtool
> autoreconf: running: /usr/local/stow/autoconf-2.64/bin/autoconf --force
> configure.ac:447: error: possibly undefined macro: AC_LIBTOOL_WIN32_DLL
> If this token and others are legitimate, please use m4_pattern_allow.
> See the Autoconf documentation.
> autoreconf: /usr/local/stow/autoconf-2.64/bin/autoconf failed with exit
> status: 1
>
> Brice
>
> _______________________________________________
> hwloc-devel mailing list
> hwloc-devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/hwloc-devel
>

-- 
Jeff Squyres
jsquyres_at_[hidden]