Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] [hwloc-svn] svn:hwloc r1447
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-12-08 13:20:47


On Dec 8, 2009, at 1:17 PM, Brice Goglin wrote:

>> New require LT 2.2.6b
>
> By the way, isn't LT_INIT supposed to enforce the required version? We
> had a bug report from somebody running libtool 1.5 (in the libpci
> branch). He got obscur errors during autogen.sh, but nothing said
> clearly that his libtool was too old...

We could do that (I think it's actually LT_PREREQ). The control I bumped was in the "make a dist tarball" script, not in configure.ac itself -- meaning that we only cared about the version that went out in official tarballs; developers had a little more freedom for their own development copies.

If you want to be a bit stricter on developers, I'm fine with that, too.

-- 
Jeff Squyres
jsquyres_at_[hidden]