Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: [hwloc-devel] update libtool/autoconf
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-12-08 13:17:14


I updated the v0.9 branch to require LT 2.2.6b to build tarballs, and the trunk to require AC 2.65 (the latest) and LT 2.2.6b.

Libltdl (shipped in libtool) had a security issue that was patched in 2.2.6b. The issue doesn't affect hwloc (hwloc doesn't even use libltdl -- yet), but I didn't want any red flags to be raised because we were using an "insecure" LT version. I took the liberty of updating our AC version on the trunk just for the heckuvit.

-- 
Jeff Squyres
jsquyres_at_[hidden]