Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: [hwloc-devel] hwloc 0.9.2 autogen issue
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-11-05 14:50:56


(re-subjected to be accurate)

I notice that my autogen.sh outputs:

autoreconf: running: aclocal -I m4 --force -I config

but yours outputs:

autoreconf: running: aclocal --force -I config

where's the "-I m4"?

....ah, I see you're running AC 2.63. I'm running AC 2.64. I just
tried with AC 2.63 and I see the same problem. Lemme see if I can get
a workaround.

On Nov 5, 2009, at 2:18 PM, Pavan Balaji wrote:

>
> Am I supposed to do something special here for hwloc-0.9.2?
>
> % autoconf --version
> autoconf (GNU Autoconf) 2.63
> Copyright (C) 2008 Free Software Foundation, Inc.
> License GPLv2+: GNU GPL version 2 or later
> <http://gnu.org/licenses/old-licenses/gpl-2.0.html>
> This is free software: you are free to change and redistribute it.
> There is NO WARRANTY, to the extent permitted by law.
>
> % libtool --version
> ltmain.sh (GNU libtool) 2.2.6
> Written by Gordon Matzigkeit <gord_at_[hidden]>, 1996
>
> % ./autogen.sh
> autoreconf: Entering directory `.'
> autoreconf: configure.ac: not using Gettext
> autoreconf: running: aclocal --force -I config
> autoreconf: configure.ac: tracing
> autoreconf: running: libtoolize --copy --force
> libtoolize: putting auxiliary files in AC_CONFIG_AUX_DIR, `config'.
> libtoolize: copying file `config/ltmain.sh'
> libtoolize: putting macros in AC_CONFIG_MACRO_DIR, `config'.
> libtoolize: copying file `config/libtool.m4'
> libtoolize: copying file `config/ltoptions.m4'
> libtoolize: copying file `config/ltsugar.m4'
> libtoolize: copying file `config/ltversion.m4'
> libtoolize: copying file `config/lt~obsolete.m4'
> autoreconf: running: /home/balaji/software/tools/install/bin/autoconf
> --include=m4 --force
> configure.ac:163: error: possibly undefined macro: AC_DEFINE
> If this token and others are legitimate, please use
> m4_pattern_allow.
> See the Autoconf documentation.
> autoreconf: /home/balaji/software/tools/install/bin/autoconf failed
> with
> exit status: 1
>
> -- Pavan
>
> On 11/04/2009 03:55 PM, Jeff Squyres wrote:
> > Please beat it up and look for problems!
> >
> > http://www.open-mpi.org/software/hwloc/v0.9/
> >
>
> --
> Pavan Balaji
> http://www.mcs.anl.gov/~balaji
> _______________________________________________
> hwloc-devel mailing list
> hwloc-devel_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/hwloc-devel
>

-- 
Jeff Squyres
jsquyres_at_[hidden]