Fawzi Mohamed wrote:
> ok as I said to me it is not so strange (maybe init/clear would be a
> better name though), but indeed it might confuse people, so probably
> better avoid it.
> Force the user to to the right thing is better.
> So the question remains, opaque + functions, or public...
I haven't had time to actually fully implement this yet, but my last
plan was opaque pointer + functions such as:
void hwloc_cpuset_destroy(hwloc_cpuset_t cpuset);
hwloc_cpuset_t hwloc_cpuset_copy(hwloc_cpuset_t cpuset);
typedef struct hwloc_cpuset_s * hwloc_cpuset_t;