Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] last API possible changes
From: Samuel Thibault (samuel.thibault_at_[hidden])
Date: 2009-09-20 18:12:07


Brice Goglin, le Thu 17 Sep 2009 09:50:57 +0200, a écrit :
> * Do we actually need hwloc_get_type_order() or would
> hwloc_compare_types() be enough? I can't find any example where some
> type "orders" is not used for direct comparison.

And the latter is probably clearer, indeed.

> * I think the _above_cpuset() and _below_cpuset() function names are not
> very clear. I think "inside" may be better that "below" (and rename
> get_cpuset_objs into get_objs_inside_cpuset as well and move it nearby).
> And maybe use "covering" instead of "above" since we already have
> "covering" somewhere else?

That should be fine, yes.

> Also, we have __hwloc_restrict everywhere in the public API, but also in
> the manpages? Should we convert the latter into a regular "restrict"
> keyword ?

I had tried before already through the .cfg and that didn't work. Since
we now have our own Makefile rules, I've just added a sed call, which
also does the same for inline btw.

> That's all for today :) Better fix this now instead of changing the ABI
> after the first hwloc release.

Sure :)

Samuel