On Sep 15, 2009, at 2:07 AM, Brice Goglin wrote:
> I just gave a deep look and fixed several minor things in the API. The
> biggest thing I am not sure about is:
> We currently have several functions that may find something by type or
> by depth (for instance the number of objects, the n-th one, the next
> one, ...). These functions are currently named
> "hwloc_get_foo_by_depth(..., depth)" if looking by depth and
> "hwloc_get_foo(..., type)" if by type. The latter may fail if there
> multiple levels with same types (e.g. Caches), the former always work
> (unless depth is invalid). Should we keep these function name patterns
> or change them to something else? like _by_depth/_by_type or
I prefer being explicit -- so _by_type / _by_depth. My $0.02.
> Also, make distcheck currently fails here. It looks for index.html
> inside the build dir while it should look inside the source dir.
> However, it seems that it correctly looks inside the source dir when
> building outside of make distcheck. Don't know what's going on...
I'm unable to recreate this. Can you give me a recipe to recreate