Open MPI logo

Docs Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Docs mailing list

Subject: Re: [OMPI docs] Open MPI compilation Error
From: Ralph Castain (rhc_at_[hidden])
Date: 2011-10-17 09:40:54


Indeed. However, let me provide this advice. Add --disable-vt to your configure line, and drop all the rest of those flags. You don't need what you gave as we'll automatically figure those out. VampirTrace isn't happy on Mac, so disable it and you should be fine.

On Oct 17, 2011, at 7:29 AM, Jeff Squyres wrote:

> I think you want to redirect your question to the users list, not the documentation list.
>
>
> On Oct 17, 2011, at 8:02 AM, Rashid, Z. (Zahid) wrote:
>
>> Dear Open MPI users,
>>
>> I am trying to compile open MPI (release 1.5.4) from the source code on a Macbook Pro (OS X Lion) with Xcode 4.1 installed. I configure the openmpi with the following options;
>>
>> ../configure CFLAGS=-m64 CXXFLAGS=-m64 FFLAGS=-m64 FCFLAGS=-m64 --with-wrapper-cflags=-m64 --with-wrapper-cxxflags=-m64
>>
>> in a new/clean directory. When I try make it gives me the following error;
>>
>> Making all in otfprofile
>> CXX otfprofile-otfprofile.o
>> CXX otfprofile-CSVParse.o
>> CXX otfprofile-DataStructure.o
>> CXX otfprofile-Handler.o
>> CXX otfprofile-Prodtex.o
>> CXX otfprofile-Summary.o
>> CXXLD otfprofile
>> Undefined symbols for architecture x86_64:
>> "___builtin_expect", referenced from:
>> _main.omp_fn.0 in otfprofile-otfprofile.o
>> ld: symbol(s) not found for architecture x86_64
>> collect2: ld returned 1 exit status
>> make[9]: *** [otfprofile] Error 1
>> make[8]: *** [all-recursive] Error 1
>> make[7]: *** [all-recursive] Error 1
>> make[6]: *** [all] Error 2
>> make[5]: *** [all-recursive] Error 1
>> make[4]: *** [all-recursive] Error 1
>> make[3]: *** [all] Error 2
>> make[2]: *** [all-recursive] Error 1
>> make[1]: *** [all-recursive] Error 1
>> make: *** [all-recursive] Error 1
>>
>> I have gcc version 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2335.15.00), gfortran GNU Fortran (GCC) 4.2.1 (Apple Inc. build 5666) (dot 3) I heard that I can use MacPorts for an easy installation but I want to compile it myself from the source. Can someone suggest me if I need to set some extra flags or what is causing this error? Please let me know if you need any further information.
>>
>> Regards.
>>
>> Zahid
>>
>> _______________________________________________
>> docs mailing list
>> docs_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/docs
>
>
> --
> Jeff Squyres
> jsquyres_at_[hidden]
> For corporate legal information go to:
> http://www.cisco.com/web/about/doing_business/legal/cri/
>
>
> _______________________________________________
> docs mailing list
> docs_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/docs