Open MPI logo

Docs Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Docs mailing list

Subject: Re: [OMPI docs] Errors in man pages (on the web, anyway), dead wiki
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2010-07-29 15:17:13


Awesome -- thanks!

On Jul 29, 2010, at 1:10 PM, Ralph Castain wrote:

> I might be able to take a look at this for you...
>
> On Jul 29, 2010, at 10:00 AM, Jeff Squyres wrote:
>
> > On Jul 28, 2010, at 8:58 PM, Radu C wrote:
> >
> >> Having no way to send a report without subscribing to a mailing list, here I am...
> >>
> >> I just started looking into Open MPI, and so far I found a few errors in the man pages that are posted on the Open MPI website:
> >>
> >> http://www.open-mpi.org/doc/v1.4/man3/MPI.3.php
> >> http://www.open-mpi.org/doc/v1.4/man3/OpenMPI.3.php
> >>
> >> Note that MPI does not guarantee that an MPI pro-
> >> MPI_ERR_BUFFER 1 Invalid buffer pointer.
> >
> > Ugh. It looks like all of these are bugs in the man2html. I spent a bunch of time twonking around trying to figure out how to get reasonable output but failed. :-(
> >
> > Does anyone have any time to look at this, perchance? I wrote a simple perl script to generate all of those man pages:
> >
> > https://svn.open-mpi.org/trac/ompi/browser/trunk/contrib/dist/make-html-man-pages.pl
> >
> > It takes 2 arguments; you run it like this:
> >
> > ./make-html-man-pages --mandir /path/to/openmpi/share/man --version 1.4.2
> >
> > Where the /path... is the directory where the 1.4.2 man pages were installed. It should generate a pile of .php files alongside all of the existing man pages (so you might not want to run this in a production installation). After it runs, look at man/man3/MPI.3.php -- you'll see that it's just snipped. :-(
> >
> >> Haven't checked other man pages. Still looking for a "Hello World" tutorial, to have a taste of Open MPI, see if I like it and if I'd like some more, on this page: http://www.open-mpi.org/projects/user-docs/ I followed the link to the wiki: https://svn.open-mpi.org/trac/ompi-user-docs/wiki. But it says Environment not found. Ended up on Google, as suggested by the FAQ. Hope I like what I see :)
> >
> > Ick. I'll see if I can get that fixed. As noted on the web page, the user-docs sub project has fallen through the cracks and is in desperate need of a leader. Any volunteers?
> >
> > --
> > Jeff Squyres
> > jsquyres_at_[hidden]
> > For corporate legal information go to:
> > http://www.cisco.com/web/about/doing_business/legal/cri/
> >
> >
> > _______________________________________________
> > docs mailing list
> > docs_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/docs
>
>
> _______________________________________________
> docs mailing list
> docs_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/docs
>

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/