Open MPI logo

Docs Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Docs mailing list

Subject: Re: [OMPI docs] build proxy agent for eclipse
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2008-10-06 14:05:26


Two points:

1. I think it's the PTP team that will need to comment on this issue;
they are the maintainers of all of the Eclipse/OMPI integration stuff.

2. The "docs" list is for Open MPI documentation issues, not for user-
level questions or bug reports. Thanks.

On Oct 2, 2008, at 4:28 PM, Yen Phi wrote:

> Hi all,
> When I run "sh BUILD" to build proxy agent for eclipse ptp, it
> doesn't have any error and I have ptp_orte_proxy.o and smd.o. But I
> can't start resource manager. When I check config.log, I see some
> error. This is config.log file:
>
> This file contains any messages produced by compilers while
> running configure, to aid debugging if configure makes a mistake.
>
> It was created by org.eclipse.ptp.orte configure 2.0.0, which was
> generated by GNU Autoconf 2.61. Invocation command line was
>
> $ configure --prefix=/home/blackbird/requires/eclipse/plugins/
> org.eclipse.ptp.linux.x86_2.0.0.200804010706
>
> ## --------- ##
> ## Platform. ##
> ## --------- ##
>
> hostname = phi-yen.lan
> uname -m = i686
> uname -r = 2.6.18-53.el5
> uname -s = Linux
> uname -v = #1 SMP Mon Nov 12 02:22:48 EST 2007
>
> /usr/bin/uname -p = unknown
> /bin/uname -X = unknown
>
> /bin/arch = i686
> /usr/bin/arch -k = unknown
> /usr/convex/getsysinfo = unknown
> /usr/bin/hostinfo = unknown
> /bin/machine = unknown
> /usr/bin/oslevel = unknown
> /bin/universe = unknown
>
> PATH: /home/blackbird/require/jdk1.5.0_16/bin
> PATH: /usr/local/bin
> PATH: .
> PATH: /home/blackbird/require/jdk1.5.0_16/bin
> PATH: .
> PATH: /home/blackbird/requires/jre1.5.0_15/bin
> PATH: /usr/local/bin
> PATH: /home/blackbird/requires/jre1.5.0_15/bin
> PATH: /usr/local/bin
> PATH: /home/blackbird/requires/jre1.5.0_15/bin
> PATH: /usr/local/bin
> PATH: /usr/lib/qt-3.3/bin
> PATH: /usr/kerberos/sbin
> PATH: /usr/kerberos/bin
> PATH: /usr/local/sbin
> PATH: /usr/local/bin
> PATH: /sbin
> PATH: /bin
> PATH: /usr/sbin
> PATH: /usr/bin
> PATH: /usr/X11R6/bin
>
>
> ## ----------- ##
> ## Core tests. ##
> ## ----------- ##
>
> configure:1745: checking for a BSD-compatible install
> configure:1801: result: /usr/bin/install -c
> configure:1812: checking whether build environment is sane
> configure:1855: result: yes
> configure:1920: checking for gawk
> configure:1936: found /bin/gawk
> configure:1947: result: gawk
> configure:1958: checking whether make sets $(MAKE)
> configure:1979: result: yes
> configure:2170: checking build system type
> configure:2188: result: i686-pc-linux-gnu
> configure:2287: checking for mpicc
> configure:2303: found /usr/local/bin/mpicc
> configure:2314: result: mpicc
> configure:2350: checking for C compiler version
> configure:2357: mpicc --version >&5
> gcc (GCC) 4.1.2 20070626 (Red Hat 4.1.2-14)
> Copyright (C) 2006 Free Software Foundation, Inc.
> This is free software; see the source for copying conditions. There
> is NO
> warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR
> PURPOSE.
>
> configure:2360: $? = 0
> configure:2367: mpicc -v >&5
> Using built-in specs.
> Target: i386-redhat-linux
> Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
> --infodir=/usr/share/info --enable-shared --enable-threads=posix --
> enable-checking=release --with-system-zlib --enable-__cxa_atexit --
> disable-libunwind-exceptions --enable-libgcj-multifile --enable-
> languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk
> --disable-dssi --enable-plugin --with-java-home=/usr/lib/jvm/
> java-1.4.2-gcj-1.4.2.0/jre --with-cpu=generic --host=i386-redhat-linux
> Thread model: posix
> gcc version 4.1.2 20070626 (Red Hat 4.1.2-14)
> configure:2370: $? = 0
> configure:2377: mpicc -V >&5
> gcc: '-V' option must have argument
> configure:2380: $? = 1
> configure:2403: checking for C compiler default output file name
> configure:2430: mpicc conftest.c >&5
> configure:2433: $? = 0
> configure:2471: result: a.out
> configure:2488: checking whether the C compiler works
> configure:2498: ./a.out
> configure:2501: $? = 0
> configure:2518: result: yes
> configure:2525: checking whether we are cross compiling
> configure:2527: result: no
> configure:2530: checking for suffix of executables
> configure:2537: mpicc -o conftest conftest.c >&5
> configure:2540: $? = 0
> configure:2564: result:
> configure:2570: checking for suffix of object files
> configure:2596: mpicc -c conftest.c >&5
> configure:2599: $? = 0
> configure:2622: result: o
> configure:2626: checking whether we are using the GNU C compiler
> configure:2655: mpicc -c conftest.c >&5
> configure:2661: $? = 0
> configure:2678: result: yes
> configure:2683: checking whether mpicc accepts -g
> configure:2713: mpicc -c -g conftest.c >&5
> configure:2719: $? = 0
> configure:2818: result: yes
> configure:2835: checking for mpicc option to accept ISO C89
> configure:2909: mpicc -c -g -O2 conftest.c >&5
> configure:2915: $? = 0
> configure:2938: result: none needed
> configure:2967: checking for style of include used by make
> configure:2995: result: GNU
> configure:3023: checking dependency style of mpicc
> configure:3113: result: gcc3
> configure:3131: checking whether mpicc and cc understand -c and -o
> together
> configure:3166: mpicc -c conftest.c -o conftest2.o >&5
> configure:3169: $? = 0
> configure:3175: mpicc -c conftest.c -o conftest2.o >&5
> configure:3178: $? = 0
> configure:3189: cc -c conftest.c >&5
> configure:3192: $? = 0
> configure:3200: cc -c conftest.c -o conftest2.o >&5
> configure:3203: $? = 0
> configure:3209: cc -c conftest.c -o conftest2.o >&5
> configure:3212: $? = 0
> configure:3230: result: yes
> configure:3268: checking for a BSD-compatible install
> configure:3324: result: /usr/bin/install -c
> configure:3335: checking whether make sets $(MAKE)
> configure:3356: result: yes
> configure:3408: checking for ranlib
> configure:3424: found /usr/bin/ranlib
> configure:3435: result: ranlib
> configure:3467: checking for bitset_new in -lutils
> configure:3502: mpicc -o conftest -g -O2 -Wall -I../
> org.eclipse.ptp.utils_2.0.0.200804010706/include -I../
> org.eclipse.ptp.proxy_2.0.0.200804010706/include conftest.c -
> lutils -L../org.eclipse.ptp.utils_2.0.0.200804010706 -L../
> org.eclipse.ptp.proxy_2.0.0.200804010706 >&5
> configure:3508: $? = 0
> configure:3526: result: yes
> configure:3538: checking for proxy_svr_init in -lproxysvr
> configure:3573: mpicc -o conftest -g -O2 -Wall -I../
> org.eclipse.ptp.utils_2.0.0.200804010706/include -I../
> org.eclipse.ptp.proxy_2.0.0.200804010706/include conftest.c -
> lproxysvr -lutils -L../org.eclipse.ptp.utils_2.0.0.200804010706 -
> L../org.eclipse.ptp.proxy_2.0.0.200804010706 >&5
> configure:3579: $? = 0
> configure:3597: result: yes
> configure:3615: checking how to run the C preprocessor
> configure:3655: mpicc -E conftest.c
> configure:3661: $? = 0
> configure:3692: mpicc -E conftest.c
> conftest.c:12:28: error: ac_nonexistent.h: No such file or directory
> configure:3698: $? = 1
> configure: failed program was:
> | /* confdefs.h. */
> | #define PACKAGE_NAME "org.eclipse.ptp.orte"
> | #define PACKAGE_TARNAME "org-eclipse-ptp-orte"
> | #define PACKAGE_VERSION "2.0.0"
> | #define PACKAGE_STRING "org.eclipse.ptp.orte 2.0.0"
> | #define PACKAGE_BUGREPORT ""
> | #define PACKAGE "org-eclipse-ptp-orte"
> | #define VERSION "2.0.0"
> | #define HAVE_LIBUTILS 1
> | #define HAVE_LIBPROXYSVR 1
> | /* end confdefs.h. */
> | #include <ac_nonexistent.h>
> configure:3731: result: mpicc -E
> configure:3760: mpicc -E conftest.c
> configure:3766: $? = 0
> configure:3797: mpicc -E conftest.c
> conftest.c:12:28: error: ac_nonexistent.h: No such file or directory
> configure:3803: $? = 1
> configure: failed program was:
> | /* confdefs.h. */
> | #define PACKAGE_NAME "org.eclipse.ptp.orte"
> | #define PACKAGE_TARNAME "org-eclipse-ptp-orte"
> | #define PACKAGE_VERSION "2.0.0"
> | #define PACKAGE_STRING "org.eclipse.ptp.orte 2.0.0"
> | #define PACKAGE_BUGREPORT ""
> | #define PACKAGE "org-eclipse-ptp-orte"
> | #define VERSION "2.0.0"
> | #define HAVE_LIBUTILS 1
> | #define HAVE_LIBPROXYSVR 1
> | /* end confdefs.h. */
> | #include <ac_nonexistent.h>
> configure:3841: checking for grep that handles long lines and -e
> configure:3915: result: /bin/grep
> configure:3920: checking for egrep
> configure:3998: result: /bin/grep -E
> configure:4003: checking for ANSI C header files
> configure:4033: mpicc -c -g -O2 -Wall -I../
> org.eclipse.ptp.utils_2.0.0.200804010706/include -I../
> org.eclipse.ptp.proxy_2.0.0.200804010706/include conftest.c >&5
> configure:4039: $? = 0
> configure:4138: mpicc -o conftest -g -O2 -Wall -I../
> org.eclipse.ptp.utils_2.0.0.200804010706/include -I../
> org.eclipse.ptp.proxy_2.0.0.200804010706/include conftest.c -
> lproxysvr -lutils -L../org.eclipse.ptp.utils_2.0.0.200804010706 -
> L../org.eclipse.ptp.proxy_2.0.0.200804010706 >&5
> configure:4141: $? = 0
> configure:4147: ./conftest
> configure:4150: $? = 0
> configure:4167: result: yes
> configure:4178: checking return type of signal handlers
> configure:4206: mpicc -c -g -O2 -Wall -I../
> org.eclipse.ptp.utils_2.0.0.200804010706/include -I../
> org.eclipse.ptp.proxy_2.0.0.200804010706/include conftest.c >&5
> conftest.c: In function 'main':
> conftest.c:19: error: void value not ignored as it ought to be
> configure:4212: $? = 1
> configure: failed program was:
> | /* confdefs.h. */
> | #define PACKAGE_NAME "org.eclipse.ptp.orte"
> | #define PACKAGE_TARNAME "org-eclipse-ptp-orte"
> | #define PACKAGE_VERSION "2.0.0"
> | #define PACKAGE_STRING "org.eclipse.ptp.orte 2.0.0"
> | #define PACKAGE_BUGREPORT ""
> | #define PACKAGE "org-eclipse-ptp-orte"
> | #define VERSION "2.0.0"
> | #define HAVE_LIBUTILS 1
> | #define HAVE_LIBPROXYSVR 1
> | #define STDC_HEADERS 1
> | /* end confdefs.h. */
> | #include <sys/types.h>
> | #include <signal.h>
> |
> | int
> | main ()
> | {
> | return *(signal (0, 0)) (0) == 1;
> | ;
> | return 0;
> | }
> configure:4227: result: void
> configure:4238: checking for orted
> configure:4256: found /usr/local/bin/orted
> configure:4269: result: /usr/local/bin/orted
> configure:4410: creating ./config.status
>
> ## ---------------------- ##
> ## Running config.status. ##
> ## ---------------------- ##
>
> This file was extended by org.eclipse.ptp.orte config.status 2.0.0,
> which was
> generated by GNU Autoconf 2.61. Invocation command line was
>
> CONFIG_FILES =
> CONFIG_HEADERS =
> CONFIG_LINKS =
> CONFIG_COMMANDS =
> $ ./config.status
>
> on phi-yen.lan
>
> config.status:639: creating Makefile
> config.status:639: creating config.h
> config.status:901: executing depfiles commands
>
> ## ---------------- ##
> ## Cache variables. ##
> ## ---------------- ##
>
> ac_cv_build=i686-pc-linux-gnu
> ac_cv_c_compiler_gnu=yes
> ac_cv_env_CC_set=
> ac_cv_env_CC_value=
> ac_cv_env_CFLAGS_set=
> ac_cv_env_CFLAGS_value=
> ac_cv_env_CPPFLAGS_set=
> ac_cv_env_CPPFLAGS_value=
> ac_cv_env_CPP_set=
> ac_cv_env_CPP_value=
> ac_cv_env_LDFLAGS_set=
> ac_cv_env_LDFLAGS_value=
> ac_cv_env_LIBS_set=
> ac_cv_env_LIBS_value=
> ac_cv_env_build_alias_set=
> ac_cv_env_build_alias_value=
> ac_cv_env_host_alias_set=
> ac_cv_env_host_alias_value=
> ac_cv_env_target_alias_set=
> ac_cv_env_target_alias_value=
> ac_cv_header_stdc=yes
> ac_cv_lib_proxysvr_proxy_svr_init=yes
> ac_cv_lib_utils_bitset_new=yes
> ac_cv_objext=o
> ac_cv_path_EGREP='/bin/grep -E'
> ac_cv_path_GREP=/bin/grep
> ac_cv_path_ORTED=/usr/local/bin/orted
> ac_cv_path_install='/usr/bin/install -c'
> ac_cv_prog_AWK=gawk
> ac_cv_prog_CPP='mpicc -E'
> ac_cv_prog_ac_ct_CC=mpicc
> ac_cv_prog_ac_ct_RANLIB=ranlib
> ac_cv_prog_cc_c89=
> ac_cv_prog_cc_g=yes
> ac_cv_prog_cc_mpicc_c_o=yes
> ac_cv_prog_make_make_set=yes
> ac_cv_type_signal=void
> am_cv_CC_dependencies_compiler_type=gcc3
>
> ## ----------------- ##
> ## Output variables. ##
> ## ----------------- ##
>
> ACLOCAL='${SHELL} /home/blackbird/requires/eclipse/plugins/
> org.eclipse.ptp.rm.orte.proxy_2.0.0.200804010706/missing --run
> aclocal-1.9'
> AMDEPBACKSLASH='\'
> AMDEP_FALSE='#'
> AMDEP_TRUE=''
> AMTAR='${SHELL} /home/blackbird/requires/eclipse/plugins/
> org.eclipse.ptp.rm.orte.proxy_2.0.0.200804010706/missing --run tar'
> AUTOCONF='${SHELL} /home/blackbird/requires/eclipse/plugins/
> org.eclipse.ptp.rm.orte.proxy_2.0.0.200804010706/missing --run
> autoconf'
> AUTOHEADER='${SHELL} /home/blackbird/requires/eclipse/plugins/
> org.eclipse.ptp.rm.orte.proxy_2.0.0.200804010706/missing --run
> autoheader'
> AUTOMAKE='${SHELL} /home/blackbird/requires/eclipse/plugins/
> org.eclipse.ptp.rm.orte.proxy_2.0.0.200804010706/missing --run
> automake-1.9'
> AWK='gawk'
> CC='mpicc'
> CCDEPMODE='depmode=gcc3'
> CFLAGS='-g -O2 -Wall -I../org.eclipse.ptp.utils_2.0.0.200804010706/
> include -I../org.eclipse.ptp.proxy_2.0.0.200804010706/include'
> CPP='mpicc -E'
> CPPFLAGS=''
> CYGPATH_W='echo'
> DEFS='-DHAVE_CONFIG_H'
> DEPDIR='.deps'
> ECHO_C=''
> ECHO_N='-n'
> ECHO_T=''
> EGREP='/bin/grep -E'
> EXEEXT=''
> GREP='/bin/grep'
> INSTALL_DATA='${INSTALL} -m 644'
> INSTALL_PROGRAM='${INSTALL}'
> INSTALL_SCRIPT='${INSTALL}'
> INSTALL_STRIP_PROGRAM='${SHELL} $(install_sh) -c -s'
> LDFLAGS=''
> LIBOBJS=''
> LIBS='-lproxysvr -lutils -L../
> org.eclipse.ptp.utils_2.0.0.200804010706 -L../
> org.eclipse.ptp.proxy_2.0.0.200804010706'
> LTLIBOBJS=''
> MAKEINFO='${SHELL} /home/blackbird/requires/eclipse/plugins/
> org.eclipse.ptp.rm.orte.proxy_2.0.0.200804010706/missing --run
> makeinfo'
> OBJEXT='o'
> ORTED='/usr/local/bin/orted'
> PACKAGE='org-eclipse-ptp-orte'
> PACKAGE_BUGREPORT=''
> PACKAGE_NAME='org.eclipse.ptp.orte'
> PACKAGE_STRING='org.eclipse.ptp.orte 2.0.0'
> PACKAGE_TARNAME='org-eclipse-ptp-orte'
> PACKAGE_VERSION='2.0.0'
> PATH_SEPARATOR=':'
> RANLIB='ranlib'
> SET_MAKE=''
> SHELL='/bin/sh'
> STRIP=''
> VERSION='2.0.0'
> ac_ct_CC='mpicc'
> am__fastdepCC_FALSE='#'
> am__fastdepCC_TRUE=''
> am__include='include'
> am__leading_dot='.'
> am__quote=''
> am__tar='${AMTAR} chof - "$$tardir"'
> am__untar='${AMTAR} xf -'
> bindir='${exec_prefix}/bin'
> build='i686-pc-linux-gnu'
> build_alias=''
> build_cpu='i686'
> build_os='linux-gnu'
> build_vendor='pc'
> datadir='${datarootdir}'
> datarootdir='${prefix}/share'
> docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
> dvidir='${docdir}'
> exec_prefix='${prefix}'
> host_alias=''
> htmldir='${docdir}'
> includedir='${prefix}/include'
> infodir='${datarootdir}/info'
> install_sh='/home/blackbird/requires/eclipse/plugins/
> org.eclipse.ptp.rm.orte.proxy_2.0.0.200804010706/install-sh'
> libdir='${exec_prefix}/lib'
> libexecdir='${exec_prefix}/libexec'
> localedir='${datarootdir}/locale'
> localstatedir='${prefix}/var'
> mandir='${datarootdir}/man'
> mkdir_p='mkdir -p --'
> oldincludedir='/usr/include'
> pdfdir='${docdir}'
> prefix='/home/blackbird/requires/eclipse/plugins/
> org.eclipse.ptp.linux.x86_2.0.0.200804010706'
> program_transform_name='s,x,x,'
> psdir='${docdir}'
> sbindir='${exec_prefix}/sbin'
> sharedstatedir='${prefix}/com'
> sysconfdir='${prefix}/etc'
> target_alias=''
>
> ## ----------- ##
> ## confdefs.h. ##
> ## ----------- ##
>
> #define PACKAGE_NAME "org.eclipse.ptp.orte"
> #define PACKAGE_TARNAME "org-eclipse-ptp-orte"
> #define PACKAGE_VERSION "2.0.0"
> #define PACKAGE_STRING "org.eclipse.ptp.orte 2.0.0"
> #define PACKAGE_BUGREPORT ""
> #define PACKAGE "org-eclipse-ptp-orte"
> #define VERSION "2.0.0"
> #define HAVE_LIBUTILS 1
> #define HAVE_LIBPROXYSVR 1
> #define STDC_HEADERS 1
> #define RETSIGTYPE void
> #define OMPI 1
> #define ORTED "/usr/local/bin/orted"
>
> configure: exit 0
>
> OpenMPI that I use is the version supporting checkpoint/restart
> (trunk r16603). Because it differ from openMPI_1.2,, I change
> something in org.eclipse.ptp.rm.orte.proxy_.../src/orte_fixup.h and
> org.eclipse.ptp.rm.orte.proxy_.../src/ptp_orte_proxy.c .
>
> In org.eclipse.ptp.rm.orte.proxy_.../src/orte_fixup.h:
> line 35: orte/tools/orted/orte.h -> orte/orted/orted.h
> line 93 - 192: orte_ns.create_process_name(&name, 0, jobid, 0) ->
> orte_ns.create_process_name(&name, jobid, 0)
> line 314: orte_pls.terminate_orteds(jobid, &timeout, &attr) ->
> orte_pls.terminate_orteds( &timeout, &attr)
>
> In org.eclipse.ptp.rm.orte.proxy_.../src/ptp_orte_proxy.c:
> line 771 - 807: orte_ns.create_process_name(&name, 0, jobid, 0) ->
> orte_ns.create_process_name(&name, jobid, 0)
> line 870: delete #else /*ORTE_VERSION_1_0*/ case
> ORTE_JOB_STATE_AT_STG2
>
> I check all my steps I did when install eclipse ptp but nothing
> wrong. I don't know why I can't start resoure manager. Please tell
> me what wrong.
> Thanks
> Yen
>
> _______________________________________________
> docs mailing list
> docs_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/docs

-- 
Jeff Squyres
Cisco Systems