Hi Jeff,

I could reproduce the linker problem with the sf.net GCC. Thanks for your hint.
A header include was missing for STL's functional objects. :-(


Matthias


On Do, 2008-01-10 at 13:21 -0500, Jeff Squyres wrote:
On Jan 10, 2008, at 10:19 AM, Andreas Knüpfer wrote:

> unfortunately, we're unable to reproduce this error. Could you pass  
> some more
> information about your configure command line? This was done with  
> gcc 4.2 on
> mac os X, wasn't it?

I'm on Leopard on my MBP with:

./configure --prefix=/Users/jsquyres/bogus --enable-mpi-f90 --without- 
threads

But I might see the problem here -- I just realized/remembered that  
I'm using the sf.net GCC install (hpc.sf.net).  If I force /usr/bin/ 
gcc (and friends), it seems to work:

./configure --prefix=/Users/jsquyres/bogus CC=/usr/bin/gcc CXX=/usr/ 
bin/g++ --disable-mpi-fortran

However, the hpc.sf.net OS X compilers are not uncommon (because they  
provide fortran compiler support for OS X).  Do you think you'll be  
able to test with these compilers?

--
Matthias Jurenz,
Center for Information Services and
High Performance Computing (ZIH), TU Dresden,
Willersbau A106, Zellescher Weg 12, 01062 Dresden
phone +49-351-463-31945, fax +49-351-463-37773