I wonder if the reason PGI V10.x does not use mpi_f08 bindings is that old PGI compiler version number parsing error.  (Unless, of course, if PGI V11.x or V12.x do use mpi_f08 bindings.)  In that old (autoconf?) bug, decisions were made about features supported on PGI compilers by parsing the version number of the compiler.  Trouble was, only the first digit was examined, leading to PGI V10.x, V11.x, V12.x, ..., all being parsed as V1.  My recollection is that some C++ code was affected.

Larry Baker
US Geological Survey
650-329-5608
baker@usgs.gov



On 9 Jan 2014, at 4:35 PM, Paul Hargrove wrote:

My attempts to build the current 1.7.4rc tarball with versions 8.0 and 9.0 of the Portland Group compilers fails miserably on compilation of mpi-f08-types.F90.

I am sort of surprised by the attempt to build Fortran 2008 support w/ such old compilers.
I think that fact itself is the real bug here, right? 

With pgi-10.0 I see configure say:
checking if building Fortran 'use mpi' bindings... yes
checking if building Fortran 'use mpi_f08' bindings... no

But pgi-8.0 and 9.0 both get identified as "good" compilers.

pgi-9.0:
checking if building Fortran 'use mpi' bindings... yes
checking if Fortran compiler supports BIND(C)... yes
checking if Fortran compiler supports BIND(C) with LOGICAL params... yes
checking if Fortran compiler supports optional arguments... yes
checking if Fortran compiler supports private... no
checking if Fortran compiler supports abstract... yes
checking if Fortran compiler supports asynchronous... no
checking if Fortran compiler supports procedure... no
checking size of Fortran type(test_mpi_handle)... 4
checking Fortran compiler F08 assumed rank syntax... not cached; checking
checking for Fortran compiler support of TYPE(*), DIMENSION(..)... no
checking Fortran compiler F08 assumed rank syntax... no
checking which mpi_f08 implementation to build... "good" compiler, no array subsections
configure: WARNING: Temporary development override: forcing the use of F08 wrappers
checking if building Fortran 'use mpi_f08' bindings... yes

pgi-8.0 (almost, but not quite, the same):
checking if building Fortran 'use mpi' bindings... yes
checking if Fortran compiler supports BIND(C)... yes
checking if Fortran compiler supports BIND(C) with LOGICAL params... yes
checking if Fortran compiler supports optional arguments... yes
checking if Fortran compiler supports private... no
checking if Fortran compiler supports abstract... no
checking if Fortran compiler supports asynchronous... no
checking if Fortran compiler supports procedure... no
checking size of Fortran type(test_mpi_handle)... 4
checking Fortran compiler F08 assumed rank syntax... not cached; checking
checking for Fortran compiler support of TYPE(*), DIMENSION(..)... no
checking Fortran compiler F08 assumed rank syntax... no
checking which mpi_f08 implementation to build... "good" compiler, no array subsections
configure: WARNING: Temporary development override: forcing the use of F08 wrappers
checking if building Fortran 'use mpi_f08' bindings... yes

The bzip2-compressed config.log files for pgi-8.0 and 9.0 are attached.

-Paul 

--
Paul H. Hargrove                          PHHargrove@lbl.gov
Future Technologies Group
Computer and Data Sciences Department     Tel: +1-510-495-2352
Lawrence Berkeley National Laboratory     Fax: +1-510-486-6900
<openmpi-1.7-latest-linux-x86_64-pgi-9.0-config.log.bz2><openmpi-1.7-latest-linux-x86_64-pgi-8.0-config.log.bz2>_______________________________________________
devel mailing list
devel@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/devel