For version 1.7.3 and 1.7.4a1r29747 and CUDA-support……

 

--with-cuda –with-hwloc –enable-shared and the use of -VT

 

Problems during  command: sudo make (the configure-phase runs without problems/errors):

ERROR during VT-configuration in the make-command…

 

./configure –with-cuda=/usr/local/cuda-5.5/include –with-hwloc=/usr/local/hwloc –with-hwloc-libdir=/usr/local/heloc/lib –withwith-threds=posix –enable-mpi-thread-multiple –enable-opal-multi-threads –enable-shared –with libltdl –prefix=/usr/local

 

OK

sudo make

 

Must specify: --disable-vt

 

OK

NB! Without the option: --disable-vt Error 1 (see attached file

 

Running without VT:

            Error: /usr/local/lib/openmpi/mca_pml_obl.so: undefined symbol: progress_one_cuda_htod_event

 

Suggestions for option specifications. I have followed the e-mail correspondence between

Jrg Bornschein,

Ralph Castain

 

I have changed the Makefile.am before ./configure according to attached diff.pml

However, nothing helps for neither 1.7.3 nor 1.7.4a1r29747

 

I’m out of ideas for my MPI-application (moving from COU to GPU processing). Suggestions?

 

PBSolibakke