On Nov 5, 2013, at 2:54 PM, Paul Hargrove <email@example.com> wrote:
> If this approach is to be adopted by other components (and perhaps other MPIs), then it would be important for the enumeration variable name to be derived in a UNIFORM way:
> Without a fixed value for "SOMETHING" somebody will need to read sources (or documentation) to make the connection.
This is a good point; we got a similar piece of feedback from the MPI tools group.
How about naming the state variable "<framework>_<component>"? And then that will apply to all "<framework>_<component>*" pvars.