you need to install the lt_dladvise package as well

On Aug 29, 2013, at 6:18 AM, Bibrak Qamar <bibrakc@gmail.com> wrote:

Hi all,

I have the following runtime error while running Java MPI jobs. I have check the previous answers to the mailing list regarding this issue.

The solutions were to install libtool and configure-compile-and-install openmpi again this time with the latest version of

m4
autoconfig
automake
libtools
and flex

I did all that but again the same issue that it can't load the libraries. Any remedies?



-bash-3.2$ mpirun -np 2 java Hello
[compute-0-21.local:14205] NO LT_DLADVISE - CANNOT LOAD LIBOMPI
JAVA BINDINGS FAILED TO LOAD REQUIRED LIBRARIES
[compute-0-21.local:14204] NO LT_DLADVISE - CANNOT LOAD LIBOMPI
JAVA BINDINGS FAILED TO LOAD REQUIRED LIBRARIES
-------------------------------------------------------
Primary job  terminated normally, but 1 process returned
a non-zero exit code.. Per user-direction, the job has been aborted.
-------------------------------------------------------
--------------------------------------------------------------------------
mpirun detected that one or more processes exited with non-zero status, thus causing
the job to be terminated. The first process to do so was:

  Process name: [[48748,1],1]
  Exit code:    1
--------------------------------------------------------------------------


-Bibrak
_______________________________________________
devel mailing list
devel@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/devel