If it helps, here's the output from when I run autogen.



On Jul 1, 2013, at 10:57 AM, Ralph Castain <rhc@open-mpi.org> wrote:

> Hmmm...well, I'm not sure what I can do to help. I have to agree with Jeff that something has gotten really messed up in your checkout or system. You might check to ensure you are picking up the right autotools, and perhaps re-checkout the trunk.
>
> All I can tell you is that it is building just fine on both my Mac and Linux boxes.
>
> On Jul 1, 2013, at 7:41 AM, Vasiliy <testtest_2005@ukr.net> wrote:
>
>> Dear Ralph, I believe I have run autogen.pl after a fresh full
>> checkout, and not yet after an update:
>>
>> Open MPI autogen (buckle up!)
>>
>> 1. Checking tool versions
>>
>>  Searching for autoconf
>> <stripped>
>> ...
>> - from my log
>>
>> How ../../config/autogen_found_items.m4:274 is supposed to find
>> 'opal/mca/backtrace/configure.m4' if it operates in 'opal/libltdl' ?
>>
>> Vasiliy
>>
>>
>> On Mon, Jul 1, 2013 at 4:07 PM, Ralph Castain wrote:
>>> Or you might try rerunning autogen.pl in case you updated and didn't catch that something requiring autogen changed
>>>
>>> On Jul 1, 2013, at 7:02 AM, "Jeff Squyres (jsquyres)" wrote:
>>>
>>>> Sounds like you have a busted SVN checkout -- that file exists for me:
>>>>
>>>> [10:02] jsquyres-mac:~/s/ompi3 ❯❯❯ svnversion .
>>>> 28688
>>>> [10:02] jsquyres-mac:~/s/ompi3 ❯❯❯ svn info opal/mca/backtrace/configure.m4
>>>> Path: opal/mca/backtrace/configure.m4
>>>> Name: configure.m4
>>>> Working Copy Root Path: /Users/jsquyres/dev/svn/ompi3
>>>> URL: https://svn.open-mpi.org/svn/ompi/trunk/opal/mca/backtrace/configure.m4
>>>> Repository Root: https://svn.open-mpi.org/svn/ompi
>>>> Repository UUID: 63e3feb5-37d5-0310-a306-e8a459e722fe
>>>> Revision: 28688
>>>> Node Kind: file
>>>> Schedule: normal
>>>> Last Changed Author: rhc
>>>> Last Changed Rev: 23764
>>>> Last Changed Date: 2010-09-17 19:04:06 -0400 (Fri, 17 Sep 2010)
>>>> Text Last Updated: 2013-05-24 11:39:52 -0400 (Fri, 24 May 2013)
>>>> Checksum: a6d3741b6c9ab47daf2a6af6c812c148f91793a2
>>>>
>>>>
>>>>
>>>> On Jul 1, 2013, at 9:58 AM, Vasiliy
>>>> wrote:
>>>>
>>>>> Hello,
>>>>>
>>>>> There is an error while configuring OpenMPI from the svn checkout with
>>>>> aclocal not being able to find 'opal/mca/backtrace/configure.m4',
>>>>> which, in fact, does exist there. What changes are needed to fix that?
>>>>>
>>>>> Note: it has stepped in the 'opal/libltdl' directory just before that error:
>>>>>
>>>>> *** GNU libltdl setup
>>>>> checking location of libltdl... internal copy
>>>>> configure: OMPI configuring in opal/libltdl
>>>>> configure: running /bin/sh
>>>>> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/src/openmpi-1.9.0/opal/libltdl/configure'
>>>>> '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin'
>>>>> '--sbindir=/usr/sbin' '--libexecdir=/usr/lib' '--datadir=/usr/share'
>>>>> '--localstatedir=/var' '--sysconfdir=/etc' '--datarootdir=/usr/share'
>>>>> '--docdir=/usr/share/doc/openmpi' 'LDFLAGS=-Wl,--export-all-symbols
>>>>> -Wl,-no-undefined' '--disable-mca-dso' '--disable-sysv-shmem'
>>>>> '--without-udapl' '--enable-cxx-exceptions' '--with-threads=posix'
>>>>> '--without-cs-fs' '--enable-heterogeneous'
>>>>> '--with-mpi-param_check=always'
>>>>> '--enable-contrib-no-build=vt,libompitrace'
>>>>> '--enable-mca-no-build=paffinity,installdirs-windows,timer-windows,shmem-sysv'
>>>>> 'CC=gcc' 'CFLAGS=-ggdb -march=native -mtune=native -Ofast
>>>>> -fomit-frame-pointer -pipe
>>>>> -fdebug-prefix-map=/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build=/usr/src/debug/openmpi-1.9.0-a1
>>>>> -fdebug-prefix-map=/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/src/openmpi-1.9.0=/usr/src/debug/openmpi-1.9.0-a1'
>>>>> 'LIBS=' 'CPPFLAGS=' 'CXX=g++' 'CXXFLAGS=-ggdb -march=native
>>>>> -mtune=native -Ofast -fomit-frame-pointer -pipe
>>>>> -fdebug-prefix-map=/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build=/usr/src/debug/openmpi-1.9.0-a1
>>>>> -fdebug-prefix-map=/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/src/openmpi-1.9.0=/usr/src/debug/openmpi-1.9.0-a1'
>>>>> 'FC=gfortran' 'FCFLAGS=-ggdb -march=native -mtune=native -Ofast
>>>>> -fomit-frame-pointer -pipe
>>>>> -fdebug-prefix-map=/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build=/usr/src/debug/openmpi-1.9.0-a1
>>>>> -fdebug-prefix-map=/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/src/openmpi-1.9.0=/usr/src/debug/openmpi-1.9.0-a1'
>>>>> --enable-ltdl-convenience --disable-ltdl-install --enable-shared
>>>>> --disable-static --cache-file=/dev/null
>>>>> --srcdir=/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/src/openmpi-1.9.0/opal/libltdl
>>>>> --disable-option-checking
>>>>> checking for a BSD-compatible install... /usr/bin/install -c
>>>>> <stripped>
>>>>>
>>>>> *** Final output
>>>>> checking that generated files are newer than configure... done
>>>>> <stripped>
>>>>>
>>>>> config.status: executing libtool commands
>>>>> Making all in config
>>>>> make[1]: Entering directory
>>>>> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/config'
>>>>> make[1]: Nothing to be done for 'all'.
>>>>> make[1]: Leaving directory
>>>>> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/config'
>>>>> Making all in contrib
>>>>> make[1]: Entering directory
>>>>> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/contrib'
>>>>> make[1]: Nothing to be done for 'all'.
>>>>> make[1]: Leaving directory
>>>>> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/contrib'
>>>>> Making all in opal
>>>>> make[1]: Entering directory
>>>>> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/opal'
>>>>> Making all in include
>>>>> make[2]: Entering directory
>>>>> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/opal/include'
>>>>> make  all-am
>>>>> make[3]: Entering directory
>>>>> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/opal/include'
>>>>> make[3]: Leaving directory
>>>>> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/opal/include'
>>>>> make[2]: Leaving directory
>>>>> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/opal/include'
>>>>> Making all in libltdl
>>>>> make[2]: Entering directory
>>>>> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/opal/libltdl'
>>>>> CDPATH="${ZSH_VERSION+.}:" && cd
>>>>> /usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/src/openmpi-1.9.0/opal/libltdl
>>>>> && /bin/sh /usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/src/openmpi-1.9.0/config/missing
>>>>> aclocal-1.14 -I ../../config
>>>>> aclocal-1.14: error: ../../config/autogen_found_items.m4:274: file
>>>>> 'opal/mca/backtrace/configure.m4' does not exist
>>>>> Makefile:527: recipe for target
>>>>> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/src/openmpi-1.9.0/opal/libltdl/aclocal.m4'
>>>>> failed
>>>>> make[2]: *** [/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/src/openmpi-1.9.0/opal/libltdl/aclocal.m4]
>>>>> Error 1
>>>>> make[2]: Leaving directory
>>>>> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/opal/libltdl'
>>>>> Makefile:2070: recipe for target 'all-recursive' failed
>>>>> make[1]: *** [all-recursive] Error 1
>>>>> make[1]: Leaving directory
>>>>> '/usr/src/64bit/release/openmpi/openmpi-1.9.0-a1/build/opal'
>>>>> Makefile:1578: recipe for target 'all-recursive' failed
>>>>> make: *** [all-recursive] Error 1
>>>>> *** ERROR: make failed
>>>>> _______________________________________________
>>>>> devel mailing list
>>>>> devel@open-mpi.org
>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>>>>
>>>>
>>>> --
>>>> Jeff Squyres
>>>> jsquyres@cisco.com
>>>> For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/
>>>>
>>>>
>>>> _______________________________________________
>>>> devel mailing list
>>>> devel@open-mpi.org
>>>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>>>
>>>
>>> _______________________________________________
>>> devel mailing list
>>> devel@open-mpi.org
>>> http://www.open-mpi.org/mailman/listinfo.cgi/devel
>
>
> _______________________________________________
> devel mailing list
> devel@open-mpi.org
> http://www.open-mpi.org/mailman/listinfo.cgi/devel


--
Jeff Squyres
jsquyres@cisco.com
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/