On 2/7/2012 4:25 PM, Paul H. Hargrove wrote:


On 2/7/2012 8:59 AM, Jeff Squyres wrote:
This fixes all known issues.

Well, not quite...

I've SUCCESSFULLY retested 44 out of the 55 cpu/os/compiler/abi combinations currently on my list.
I expect 9 more by the end of the day (the older/slower hosts), but two of my test hosts are down.

So far I see only two problems that remain:

+ I can't build w/ the PGI compilers on MacOS Lion.
This was previously reported in http://www.open-mpi.org/community/lists/devel/2012/01/10258.php

+ Building w/ Solaris Studio 12.2 or 12.3 on Linux x86-64, with "-m32" required setting LD_LIBRARY_PATH.
Can the LD_LIBRARY_PATH be substituted with a rpath change in LDFLAGS of the build?
This is could either be Oracle's bug in the compiler, or a libtool problem.
My report was: http://www.open-mpi.org/community/lists/devel/2012/01/10272.php

I thought I responded to the above issue.  I think this may be a OS distribution (Solaris Studio assumption) issue.  On my RH system /lib contains the 32 libraries and /lib64 has the 64 bit libs.  I assume your system may have it the other way around (/lib = 64 bit libs and /lib32 has 32 bit).  Can you confirm that your /lib contains 64 bit libs.  Also can you do a "cc -### -m32" compile and link of a simple program and confirm that the compiler is pulling in /lib (I am 99% certain it is).  Also, is this /lib is 64 bit libraries a common thing, none of my Linux systems are set up this way.

Anyways, I think maybe a note in the README is in store for such setups. 
--
Terry D. Dontje | Principal Software Engineer
Developer Tools Engineering | +1.781.442.2631
Oracle - Performance Technologies
95 Network Drive, Burlington, MA 01803
Email terry.dontje@oracle.com