Paul's probably more than likely right.  The nightly runs Oracle does using MTT and tarballs do not do autogen.sh (which I believe is not expected anyways, right).  All other builds we do using autogen.* are from an svn workspace.

--td

On 12/20/2011 8:21 PM, Paul H. Hargrove wrote:
Not too bizarre.
This probably just means that nobody has ever run autogen.sh from a tarball on a system using Sun's FORTRAN compiler.

-Paul

On 12/20/2011 5:01 PM, Ralph Castain wrote:
Bizarre - fixed it too, but no promise when that might appear in a release.

Thanks!

On Dec 20, 2011, at 5:10 PM, Paul H. Hargrove wrote:

You are welcome.
NOTE: the same issue exists in 1.4.5rc1

$ grep for-sun-fortran openmpi-1.4.5rc1/autogen.sh
    config/modify-configure-for-sun-fortran.pl
$ tar tfj openmpi-1.4.5rc1.tar.bz2 | grep modify-configure-for-sun-fortran.pl || echo NOPE
NOPE

-Paul

On 12/20/2011 3:55 PM, Ralph Castain wrote:
You are quite correct - it was indeed missing from Makefile.am! Fixed - and thanks!

On Dec 20, 2011, at 4:40 PM, Paul H. Hargrove wrote:

Regardless of any other issues the referenced file does not appear in the tarball at all:

$ tar tfj openmpi-1.5.5rc1.tar.bz2 | grep modify-configure-for-sun-fortran.pl || echo NOPE
NOPE

-Paul

On 12/20/2011 3:30 PM, Jeff Squyres wrote:
Yeah, we've known about this one and mostly ignored it.

It occurs when autogen.sh is in a non-root directory and tries to run that script in a place where it doesn't exist (it does exist in the root directory).  We hadn't previously bothered to fix it because a) it's in autogen and users won't see it, b) we've revamped autogen on the trunk such that this doesn't happen anyway, and c) it's a non-fatal error (and reflects correct behavior anyway -- we don't need that script run anywhere except the root).

I'll add it to the list, but I don't know if it'll actually get fixed.


On Dec 20, 2011, at 6:22 PM, Paul H. Hargrove wrote:

While trying to resolve the gmake-vs-bmake problem I ran autogen.sh and saw:

/home/phargrov/OMPI/openmpi-1.5.5rc1/openmpi-1.5.5rc1/autogen.sh: line 701: config/modify-configure-for-sun-fortran.pl: No such file or directory

I suspect this just requires an addition to EXTRA_DIST in config/Makefile.am

-Paul

-- 
Paul H. Hargrove                          PHHargrove@lbl.gov
Future Technologies Group
HPC Research Department                   Tel: +1-510-495-2352
Lawrence Berkeley National Laboratory     Fax: +1-510-486-6900

_______________________________________________
devel mailing list
devel@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/devel
-- 
Paul H. Hargrove                          PHHargrove@lbl.gov
Future Technologies Group
HPC Research Department                   Tel: +1-510-495-2352
Lawrence Berkeley National Laboratory     Fax: +1-510-486-6900

_______________________________________________
devel mailing list
devel@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/devel
_______________________________________________
devel mailing list
devel@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/devel
-- 
Paul H. Hargrove                          PHHargrove@lbl.gov
Future Technologies Group
HPC Research Department                   Tel: +1-510-495-2352
Lawrence Berkeley National Laboratory     Fax: +1-510-486-6900

_______________________________________________
devel mailing list
devel@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/devel

_______________________________________________
devel mailing list
devel@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/devel


--
Oracle
Terry D. Dontje | Principal Software Engineer
Developer Tools Engineering | +1.781.442.2631
Oracle - Performance Technologies
95 Network Drive, Burlington, MA 01803
Email terry.dontje@oracle.com