Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] PkgSrc build of 1.8.1 gives a portability error
From: Bert Wesarg (bert.wesarg_at_[hidden])
Date: 2014-07-17 02:28:03


On 07/17/2014 06:32 AM, Kevin Buckley wrote:
> => Checking for portability problems in extracted files
> ERROR: [check-portability.awk] => Found test ... == ...:
> ERROR: [check-portability.awk] configure: if test "$enable_oshmem" ==
> "yes" -a "$ompi_fortran_happy" == "1" -a \

Autoconf also avoids the '-a' and '-o' flag from 'test' because of
portability reasons:

http://www.hep.by/gnu/autoconf/Limitations-of-Builtins.html#index-g_t_0040command_007btest_007d-1725

Bert

-- 
Dipl.-Inf. Bert Wesarg
wiss. Mitarbeiter
Technische Universität Dresden
Zentrum für Informationsdienste und Hochleistungsrechnen (ZIH)
01062 Dresden
Tel.: +49 (351) 463-42451
Fax: +49 (351) 463-37773
E-Mail: bert.wesarg_at_[hidden]