Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI devel] [OMPI svn] svn:open-mpi r32163 - in trunk: opal/mca/base orte/tools/orterun
From: Joshua Ladd (jladd.mlnx_at_[hidden])
Date: 2014-07-16 16:08:43

Ralph warned me that no matter what decision we made, someone would
probably violently object. So, with that in mind, let me put my diplomat
hat on...

Dave, I'm sorry you view this as a "crapification" of your mpirun user
interface. Your lament is duly noted and we are happy to work with you to
come to (yet another) happy compromise. It's unfortunate that the issue
wasn't raised during the dev meeting when these decisions were made (you
were sitting right next to me while I discussed this out loud with Jeff and
Ralph.) At the time, it seemed all interested parties had expressed their
concern and voiced their opinion on the matter, and the implementation you
see in the trunk today, including the decision to deprecate the "-x"
option, was the generally agreed upon consensus.


On Wed, Jul 16, 2014 at 2:43 PM, Ralph Castain <rhc_at_[hidden]> wrote:

> On Jul 16, 2014, at 11:34 AM, Dave Goodell (dgoodell) <dgoodell_at_[hidden]>
> wrote:
> > On Jul 16, 2014, at 12:15 PM, Mike Dubman <miked_at_[hidden]>
> wrote:
> >
> >> we have a strong use-case for list of env variables passed as mca
> params.(it was presented and discussed in the past).
> >
> > I'm not disputing your use case for "mca_base_env_list". I'm only
> lamenting the crapification of our mpirun user interface. We had an
> earlier change along these lines based on similar reasoning: the
> easy-to-use-and-remember "--pernode N" was replaced with "--map-by
> ppr:N:node", which I cannot ever seem to remember.
> Same reason, I'm afraid - no way to do the mapping
> >
> >> we can rename opal_base_envlist as "-mca x var=val" for consistency.
> >> also, "-x" param now is just an alias for "-mca opal_base_envlist
> var=val" - so, we can keep it (w/o deprecation warning) as it re-uses same
> infra.
> >
> > Mike, will you make this change?
> >
> > Thanks,
> > -Dave
> > _______________________________________________
> > devel mailing list
> > devel_at_[hidden]
> > Subscription:
> > Link to this post:
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> Subscription:
> Link to this post: