On Jul 16, 2014, at 12:15 PM, Mike Dubman <miked_at_[hidden]> wrote:
> we have a strong use-case for list of env variables passed as mca params.(it was presented and discussed in the past).
I'm not disputing your use case for "mca_base_env_list". I'm only lamenting the crapification of our mpirun user interface. We had an earlier change along these lines based on similar reasoning: the easy-to-use-and-remember "--pernode N" was replaced with "--map-by ppr:N:node", which I cannot ever seem to remember.
> we can rename opal_base_envlist as "-mca x var=val" for consistency.
> also, "-x" param now is just an alias for "-mca opal_base_envlist var=val" - so, we can keep it (w/o deprecation warning) as it re-uses same infra.
Mike, will you make this change?