we have a strong use-case for list of env variables passed as mca params.(it
was presented and discussed in the past).
we can rename opal_base_envlist as "-mca x var=val" for consistency.
also, "-x" param now is just an alias for "-mca opal_base_envlist var=val"
- so, we can keep it (w/o deprecation warning) as it re-uses same infra.
On Wed, Jul 16, 2014 at 8:10 PM, Ralph Castain <rhc_at_[hidden]> wrote:
> Don't look at me - I didn't care to begin with as I never use -x and won't
> be using this param! :-)
> My point was only that having both is clunky and leads to potential
> conflict. No good solution, so <shrug>
> On Jul 16, 2014, at 9:57 AM, Dave Goodell (dgoodell) <dgoodell_at_[hidden]>
> > On Jul 16, 2014, at 11:31 AM, Ralph Castain <rhc_at_[hidden]> wrote:
> >> Nobody was "against" retaining it. The issue is that "-x" isn't an MCA
> parameter, nor does it get translated to one under the covers. So the
> problem was one of how to insert it into the typical MCA param precedence
> > I understand the combination of the two features is clunky and could
> lead to odd corner cases, but the "-x" argument is a feature I actually use
> on a fairly regular basis, but I am unlikely to use mca_base_env_list
> unless given no other choice. It's just a worse, clunkier interface unless
> one really needs to set that MCA parameter via environment variable.
> > So can we just strike the deprecation warning that is currently issued
> when "-x" is passed in the absence of "mca_base_env_list"?
> > -Dave
> > _______________________________________________
> > devel mailing list
> > devel_at_[hidden]
> > Subscription: http://www.open-mpi.org/mailman/listinfo.cgi/devel
> > Link to this post:
> devel mailing list
> Subscription: http://www.open-mpi.org/mailman/listinfo.cgi/devel
> Link to this post: