Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: [OMPI devel] ompi_info not Giving Complete Output
From: Kevin Brown (brown.k.aa_at_[hidden])
Date: 2014-05-26 10:14:33


Greetings,

I've just noticed that ompi_info (Open MPI v. 1.8.1) is not giving a
complete listing when ran with the following options:

rc000:~ > ~/opt/openmpi-1.8.1-base/bin/ompi_info --param all all
                 MCA btl: parameter "btl_tcp_if_include" (current value: "",
                          data source: default, level: 1 user/basic, type:
                          string)
                          Comma-delimited list of devices and/or CIDR
                          notation of networks to use for MPI communication
                          (e.g., "eth0,192.168.0.0/16"). Mutually exclusive
                          with btl_tcp_if_exclude.
                 MCA btl: parameter "btl_tcp_if_exclude" (current value:
                          "127.0.0.1/8,sppp", data source: default, level: 1
                          user/basic, type: string)
                          Comma-delimited list of devices and/or CIDR
                          notation of networks to NOT use for MPI
                          communication -- all devices not matching these
                          specifications will be used (e.g.,
                          "eth0,192.168.0.0/16"). If set to a non-default
                          value, it is mutually exclusive with
                          btl_tcp_if_include.
rc000:~ >

The info shown above is the only output given by the command.

Configuration info has been attached to this mail.

Is this correct behavior?

Thanks,
Kevin

------------------------------
*Kevin A. Brown* *|* Tokyo Institute of Technology *|* *E-mail*:
brown.k.aa_at_[hidden]