This RFC is now complete - the renaming exercise is done. My apologies to all for the churn, and my deepest thanks for your patience.
I know it will take awhile to get used to using the revised names and to avoid breaking the abstractions going forward. We have a "canary" for most of the abstraction breaks, so we can deal with them rather quickly when they occur.
Please let me know if/when you hit issues and we'll fix them as quickly as possible. I think the system is pretty close to right, but (as usual) there may be things in areas we can't compile that are broken.
Thanks again for your patience during this transition.
On Apr 27, 2014, at 4:39 PM, Ralph Castain <rhc_at_[hidden]> wrote:
> WHAT: continue the cleanup of build system abstractions that was started
> a couple of years ago by Brian, Jeff, and I. The objective is to fix
> all the naming conventions for things like OMPI_CHECK_PACKAGE
> so they accurately reflect their targeted level in the code base - e.g.,
> OMPI_foo gets used for things in the MPI layer. This basically just
> corrects some historical decisions made before we cared as much
> about abstractions
> WHEN: to be done in a series of commits over the next two months
> HOW: a simple search_replace.pl across the repo
> First step:
> OMPI_CHECK_PACKAGE -> OPAL_CHECK_PACKAGE
> OMPI_CHECK_FUNC_LIB -> OPAL_CHECK_FUNC_LIB
> OMPI_CHECK_COMPILER_WORKS -> OPAL_CHECK_COMPILER_WORKS
> OMPI_CHECK_WITHDIR -> OPAL_CHECK_WITHDIR
> TIMEOUT: if nobody raises an objection, sometime after the Tues telecon