Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] RFC: Well-known mca parameters
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2014-04-29 13:09:34


To close the loop for the web archives: we talked about this today on the call. The consensus was to add a new MCA var type, like Ralph suggested. It'll be a string, so you can put whatever you want in there.

And they'll prettyprint/parsable print with "version" or something obvious in there -- something to differentiate them from regular MCA string vars.

On Apr 29, 2014, at 12:33 AM, Mike Dubman <miked_at_[hidden]> wrote:

> >>> I didn't see a reply to my question about the primary use case for this being for scripts, and therefore a slightly-more-than-trivial regexp...
>
> The primary use-case:
>
> collect system related info w/ help of ompi_info and validate cluster setup is according to site/vendor rules.
> Can be done manually with help of command line or with script provided by sysadmin or vendor.
>
>
>
>
>
>
> On Tue, Apr 29, 2014 at 1:12 AM, Jeff Squyres (jsquyres) <jsquyres_at_[hidden]> wrote:
> On Apr 27, 2014, at 9:22 AM, Ralph Castain <rhc_at_[hidden]> wrote:
>
> >> Changing/updating architecture to fulfill this specific use-case seems a overkill. The arch is powerfull to resolve it w/o adding specific class (IMHO).
> >
> > Nobody would be changing the architecture of the system. All I'm suggesting is adding a new variable type. Something like "MCA_BASE_VAR_TYPE_VERSION _STRING" instead of "MCA_BASE_VAR_TYPE_STRING". This eliminates the need to force a standard param string format, and may provide a cleaner mechanism.
>
> Ralph and I chatted about this on the phone today. In principle, I'm not opposed to this. Indeed, it seems to have the added benefit that the OPAL/ORTE/OMPI/OSHMEM version numbers themselves could also be registered with this type (thereby removing some special case code from ompi_info).
>
> That being said, I just didn't want us to exclude the simple possibility first: using an MCA parameter naming convention. I didn't see a reply to my question about the primary use case for this being for scripts, and therefore a slightly-more-than-trivial regexp...
>
> --
> Jeff Squyres
> jsquyres_at_[hidden]
> For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> Subscription: http://www.open-mpi.org/mailman/listinfo.cgi/devel
> Link to this post: http://www.open-mpi.org/community/lists/devel/2014/04/14643.php
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> Subscription: http://www.open-mpi.org/mailman/listinfo.cgi/devel
> Link to this post: http://www.open-mpi.org/community/lists/devel/2014/04/14644.php

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/