On Apr 27, 2014, at 9:22 AM, Ralph Castain <rhc_at_[hidden]> wrote:
>> Changing/updating architecture to fulfill this specific use-case seems a overkill. The arch is powerfull to resolve it w/o adding specific class (IMHO).
> Nobody would be changing the architecture of the system. All I'm suggesting is adding a new variable type. Something like "MCA_BASE_VAR_TYPE_VERSION _STRING" instead of "MCA_BASE_VAR_TYPE_STRING". This eliminates the need to force a standard param string format, and may provide a cleaner mechanism.
Ralph and I chatted about this on the phone today. In principle, I'm not opposed to this. Indeed, it seems to have the added benefit that the OPAL/ORTE/OMPI/OSHMEM version numbers themselves could also be registered with this type (thereby removing some special case code from ompi_info).
That being said, I just didn't want us to exclude the simple possibility first: using an MCA parameter naming convention. I didn't see a reply to my question about the primary use case for this being for scripts, and therefore a slightly-more-than-trivial regexp...
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/