Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] RFC: Remove heterogeneous support
From: Nathan Hjelm (hjelmn_at_[hidden])
Date: 2014-04-28 13:39:01


This part of the heterogeneous support being broken was my fault. I
fixed it in r31535. I will try to spend some time over the next month or
so fixing heterogeneous support in the one-sided code. Right now the
packed datatype representation will not work if sizeof (int) is not
consistent. Not sure if we ever claimed to support this case though.

-Nathan

On Mon, Apr 28, 2014 at 09:26:36AM -0700, Ralph Castain wrote:
> I'm afraid I honestly don't remember the last time I tested with
> enable-hetero - at least 2-3 weeks ago. I'd suggest starting ~6 months ago
> and see if that still worked.
> On Apr 28, 2014, at 7:04 AM, George Bosilca <bosilca_at_[hidden]> wrote:
>
> When did you tested last? I have no idea what is broken so it is
> difficult to assess the complexity of the fix. Let's try to find the
> last working "version" and then run a dihcotomic test to find the
> culprit (with s hopefully).
> George.
> On Apr 28, 2014, at 09:05 , Ralph Castain <rhc_at_[hidden]> wrote:
>
> No, it looks like something has broken it since I last tested. Sorry
> about the confusion.
> On Apr 27, 2014, at 10:55 PM, Gilles Gouaillardet
> <gilles.gouaillardet_at_[hidden]> wrote:
>
> I might have misunderstood Jeff's comment :
>
> The broken part(s) is(are) likely somewhere in the datatype and/or PML code (my guess). Keep in mind that my only testing of this feature is in *homogeneous* mode -- i.e., I compile with --enable-heterogeneous and then run tests on homogeneous machines. Meaning: it's not only broken for actual heterogeneity, it's also broken in the "unity"/homogeneous case.
>
> Unfortunatly, a trivial send/recv can hang in this case
> (--enable-heterogeneous and homogenous cluster of little endian
> procs).
>
> i opened #4568 https://svn.open-mpi.org/trac/ompi/ticket/4568 in
> order to track this issue
> (uninitialized data can cause a hang with this config)
>
> trunk is affected, v1.8 is very likely affected too
>
> Gilles
>
> On 2014/04/28 12:22, Ralph Castain wrote:
>
> I think you misunderstood his comment. It works fine on a homogeneous cluster, even with --enable-hetero. I've run it that way on my cluster.
>
> On Apr 27, 2014, at 7:50 PM, Gilles Gouaillardet <gilles.gouaillardet_at_[hidden]> wrote:
>
>
> According to Jeff's comment, OpenMPI compiled with
> --enable-heterogeneous is broken even in an homogeneous cluster.
>
> as a first step, MTT could be ran with OpenMPI compiled with
> --enable-heterogenous and running on an homogeneous cluster
> (ideally on both little and big endian) in order to identify and fix the
> bug/regression.
> /* this build is currently disabled in the MTT config of the
> cisco-community cluster */
>
> Gilles
>
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> Subscription: http://www.open-mpi.org/mailman/listinfo.cgi/devel
> Link to this post:
> http://www.open-mpi.org/community/lists/devel/2014/04/14624.php
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> Subscription: http://www.open-mpi.org/mailman/listinfo.cgi/devel
> Link to this post:
> http://www.open-mpi.org/community/lists/devel/2014/04/14625.php
>
> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> Subscription: http://www.open-mpi.org/mailman/listinfo.cgi/devel
> Link to this post:
> http://www.open-mpi.org/community/lists/devel/2014/04/14626.php

> _______________________________________________
> devel mailing list
> devel_at_[hidden]
> Subscription: http://www.open-mpi.org/mailman/listinfo.cgi/devel
> Link to this post: http://www.open-mpi.org/community/lists/devel/2014/04/14633.php



  • application/pgp-signature attachment: stored