Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: [OMPI devel] RFC: continue cleanup of build system abstractions
From: Ralph Castain (rhc_at_[hidden])
Date: 2014-04-27 19:39:39


WHAT: continue the cleanup of build system abstractions that was started
              a couple of years ago by Brian, Jeff, and I. The objective is to fix
              all the naming conventions for things like OMPI_CHECK_PACKAGE
              so they accurately reflect their targeted level in the code base - e.g.,
              OMPI_foo gets used for things in the MPI layer. This basically just
              corrects some historical decisions made before we cared as much
              about abstractions

WHEN: to be done in a series of commits over the next two months

HOW: a simple search_replace.pl across the repo

First step:
    OMPI_CHECK_PACKAGE -> OPAL_CHECK_PACKAGE
    OMPI_CHECK_FUNC_LIB -> OPAL_CHECK_FUNC_LIB
    OMPI_CHECK_COMPILER_WORKS -> OPAL_CHECK_COMPILER_WORKS
    OMPI_CHECK_WITHDIR -> OPAL_CHECK_WITHDIR

TIMEOUT: if nobody raises an objection, sometime after the Tues telecon