Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] Missing error strings for MPI_ERR_RMA_XXX error classes
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2014-04-10 10:49:42


Thanks Lisandro; I filed https://svn.open-mpi.org/trac/ompi/ticket/4509 for this.

On Apr 10, 2014, at 7:50 AM, Lisandro Dalcin <dalcinl_at_[hidden]>
 wrote:

> I'm testing openmpi-1.8.
>
> MPI_Get_error_string() for the following error classes is failing. I
> guess you just forgot to update the list of error strings.
>
> MPI_ERR_RMA_RANGE
> MPI_ERR_RMA_ATTACH
> MPI_ERR_RMA_FLAVOR
> MPI_ERR_RMA_SHARED
>
> I'm attaching a simple test code for you to verify the issue.
>
> Additionally, please update the following comment in mpi.h
>
> /* Per MPI-3 p349 47, MPI_ERR_LASTCODE must be >= the last predefined
> MPI_ERR_<foo> code. So just set it equal to the last code --
> MPI_ERR_RMA_FLAVOR, in this case. */
> #define MPI_ERR_LASTCODE MPI_ERR_RMA_SHARED
>
> The comment is wrong, the last predefined error class is
> MPI_ERR_RMA_SHARED and not MPI_ERR_RMA_FLAVOR.
>
>
> --
> Lisandro Dalcin
> ---------------
> CIMEC (UNL/CONICET)
> Predio CONICET-Santa Fe
> Colectora RN 168 Km 472, Paraje El Pozo
> 3000 Santa Fe, Argentina
> Tel: +54-342-4511594 (ext 1016)
> Tel/Fax: +54-342-4511169
> <geterrstr.c>_______________________________________________
> devel mailing list
> devel_at_[hidden]
> Subscription: http://www.open-mpi.org/mailman/listinfo.cgi/devel
> Link to this post: http://www.open-mpi.org/community/lists/devel/2014/04/14486.php

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/